summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/libtests/Makefile.am')
-rw-r--r--testsuites/libtests/Makefile.am27
1 files changed, 13 insertions, 14 deletions
diff --git a/testsuites/libtests/Makefile.am b/testsuites/libtests/Makefile.am
index 1300a5f669..171e2e3b65 100644
--- a/testsuites/libtests/Makefile.am
+++ b/testsuites/libtests/Makefile.am
@@ -219,7 +219,7 @@ lib_screens += complex/complex.scn
complex_SOURCES = complex/init.c complex/docomplex.c \
complex/docomplexf.c complex/docomplexl.c
complex_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_complex) \
- $(support_includes) -DNO_LONG_DOUBLE
+ $(support_includes)
complex_LDADD = -lm $(LDADD)
endif
@@ -483,7 +483,7 @@ dl06-pre-tar.o: dl06-pre-tar.c dl06-pre-tar.h
$(AM_V_CC)$(COMPILE) -c -o $@ $<
dl06-pre-init.o: dl06-pre-tar.o
$(AM_V_CC)$(COMPILE) $(dl06_CPPFLAGS) $(CPU_CFLAGS) $(AM_CFLAGS) \
- -DDL06_PRE -c -o $@ $(srcdir)/dl06/init.c
+ -c -o $@ $(srcdir)/dl06/pre-init.c
dl06.pre: dl06-pre-init.o dl06/dl06-dl-load.o dl06-pre-tar.o
@rm -f $@ dl06-sym.o
$(AM_V_CCLD)$(LINK.c) $(CPU_CFLAGS) $(AM_CFLAGS) $(AM_LDFLAGS) -o $@ $+ $(LDADD)
@@ -985,8 +985,7 @@ lib_tests += mathl
lib_screens += mathl/mathl.scn
mathl_SOURCES = mathl/init.c mathl/domathl.c
mathl_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_mathl) \
- $(support_includes) -I$(top_srcdir)/math \
- -DNO_LONG_DOUBLE
+ $(support_includes) -I$(top_srcdir)/math
mathl_LDADD = -lm $(LDADD)
endif
@@ -1044,7 +1043,7 @@ lib_docs += mouse01/mouse01.doc
mouse01_SOURCES = mouse01/init.c mouse01/serial_mouse_config.c \
mouse01/msmouse.c termios04/termios_testdriver_intr.c
mouse01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_mouse01) \
- $(support_includes) -I$(top_srcdir)/termios04
+ $(support_includes)
endif
if TEST_nanosleep
@@ -1448,9 +1447,9 @@ lib_tests += termios05
lib_screens += termios05/termios05.scn
lib_docs += termios05/termios05.doc
termios05_SOURCES = termios05/init.c \
- termios04/termios_testdriver_intr.c
+ termios05/termios_testdriver_task.c
termios05_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_termios05) \
- $(support_includes) -I$(top_srcdir)/termios04 -DTASK_DRIVEN
+ $(support_includes)
endif
if TEST_termios06
@@ -1460,7 +1459,7 @@ lib_docs += termios06/termios06.doc
termios06_SOURCES = termios06/init.c \
termios03/termios_testdriver_polled.c termios06/test_pppd.c
termios06_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_termios06) \
- $(support_includes) -I$(top_srcdir)/termios03
+ $(support_includes)
endif
if TEST_termios07
@@ -1470,7 +1469,7 @@ lib_docs += termios07/termios07.doc
termios07_SOURCES = termios07/init.c \
termios04/termios_testdriver_intr.c
termios07_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_termios07) \
- $(support_includes) -I$(top_srcdir)/termios04
+ $(support_includes)
endif
if TEST_termios08
@@ -1480,7 +1479,7 @@ lib_docs += termios08/termios08.doc
termios08_SOURCES = termios08/init.c \
termios03/termios_testdriver_polled.c
termios08_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_termios08) \
- $(support_includes) -I$(top_srcdir)/termios03
+ $(support_includes)
endif
if TEST_termios09
@@ -1499,17 +1498,17 @@ lib_docs += termios10/termios10.doc
termios10_SOURCES = termios10/init.c
termios10_SOURCES += termios03/termios_testdriver_polled.c
termios10_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_termios10) \
- $(support_includes) -I$(top_srcdir)/termios03
+ $(support_includes)
endif
if TEST_termios11
lib_tests += termios11
lib_screens += termios11/termios11.scn
lib_docs += termios11/termios11.doc
-termios11_SOURCES = termios10/init.c
+termios11_SOURCES = termios11/init.c
termios11_SOURCES += termios04/termios_testdriver_intr.c
termios11_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_termios11) \
- $(support_includes) -I$(top_srcdir)/termios04 -DINTERRUPT_DRIVEN
+ $(support_includes)
endif
if TEST_top
@@ -1560,7 +1559,7 @@ lib_docs += uid01/uid01.doc
uid01_SOURCES = uid01/init.c uid01/serial_mouse_config.c \
uid01/msmouse.c termios04/termios_testdriver_intr.c
uid01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_uid01) \
- $(support_includes) -I$(top_srcdir)/termios04
+ $(support_includes)
endif
if TEST_unlink