summaryrefslogtreecommitdiffstats
path: root/testsuites/ada/tmtests/tmoverhd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/ada/tmtests/tmoverhd/Makefile.am')
-rw-r--r--testsuites/ada/tmtests/tmoverhd/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/testsuites/ada/tmtests/tmoverhd/Makefile.am b/testsuites/ada/tmtests/tmoverhd/Makefile.am
new file mode 100644
index 0000000000..8bc56dd537
--- /dev/null
+++ b/testsuites/ada/tmtests/tmoverhd/Makefile.am
@@ -0,0 +1,14 @@
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+
+include $(top_srcdir)/ada.am
+
+noinst_PROGRAMS = ada_tmoverhd
+ada_tmoverhd_SOURCES = tmoverhd.adb config.h tmtest.adb tmtest.ads \
+ dummy_rtems.adb dummy_rtems.ads
+ada_tmoverhd_SOURCES += ../../support/init.c
+
+ada_tmoverhd$(EXEEXT): tmoverhd.adb init.$(OBJEXT)
+ $(GNATCOMPILE) -margs -a $< -o $@
+
+include $(top_srcdir)/../automake/local.am