summaryrefslogtreecommitdiffstats
path: root/testsuites/ada/tmtests/tm17/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/ada/tmtests/tm17/Makefile.am')
-rw-r--r--testsuites/ada/tmtests/tm17/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/testsuites/ada/tmtests/tm17/Makefile.am b/testsuites/ada/tmtests/tm17/Makefile.am
new file mode 100644
index 0000000000..d8715ded65
--- /dev/null
+++ b/testsuites/ada/tmtests/tm17/Makefile.am
@@ -0,0 +1,13 @@
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+
+include $(top_srcdir)/ada.am
+
+noinst_PROGRAMS = ada_tm17
+ada_tm17_SOURCES = tm17.adb config.h tmtest.adb tmtest.ads
+ada_tm17_SOURCES += ../../support/init.c
+
+ada_tm17$(EXEEXT): tm17.adb init.$(OBJEXT)
+ $(GNATCOMPILE) -margs -a $< -o $@
+
+include $(top_srcdir)/../automake/local.am