summaryrefslogtreecommitdiffstats
path: root/testsuites/ada/sptests/sp12/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/ada/sptests/sp12/Makefile.am')
-rw-r--r--testsuites/ada/sptests/sp12/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/testsuites/ada/sptests/sp12/Makefile.am b/testsuites/ada/sptests/sp12/Makefile.am
new file mode 100644
index 0000000000..0a99682f1a
--- /dev/null
+++ b/testsuites/ada/sptests/sp12/Makefile.am
@@ -0,0 +1,16 @@
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+
+include $(top_srcdir)/ada.am
+
+noinst_PROGRAMS = ada_sp12
+ada_sp12_SOURCES = sp12.adb config.h sptest.adb sptest.ads
+ada_sp12_SOURCES += ../../support/init.c
+
+ada_sp12$(EXEEXT): sp12.adb init.$(OBJEXT)
+ $(GNATCOMPILE) -margs -a $< -o $@
+
+scndir = $(rtems_ada_testsdir)
+dist_scn_DATA = ada_sp12.scn
+
+include $(top_srcdir)/../automake/local.am