summaryrefslogtreecommitdiffstats
path: root/testsuites/ada/sptests/sp09/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/ada/sptests/sp09/Makefile.am')
-rw-r--r--testsuites/ada/sptests/sp09/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/testsuites/ada/sptests/sp09/Makefile.am b/testsuites/ada/sptests/sp09/Makefile.am
new file mode 100644
index 0000000000..8956a388d5
--- /dev/null
+++ b/testsuites/ada/sptests/sp09/Makefile.am
@@ -0,0 +1,21 @@
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+
+include $(top_srcdir)/ada.am
+
+# Prevents Ada from raising a constraint so that the error
+# handling can be verified in the binding.
+AM_ADAFLAGS += -gnatp
+
+noinst_PROGRAMS = ada_sp09
+
+ada_sp09_SOURCES = sp09.adb config.h sptest.adb sptest.ads
+ada_sp09_SOURCES += ../../support/init.c
+
+ada_sp09$(EXEEXT): sp09.adb init.$(OBJEXT)
+ $(GNATCOMPILE) -margs -a $< -o $@
+
+scndir = $(rtems_ada_testsdir)
+dist_scn_DATA = ada_sp09.scn
+
+include $(top_srcdir)/../automake/local.am