summaryrefslogtreecommitdiffstats
path: root/testsuites/ada/sptests/sp06/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/ada/sptests/sp06/Makefile.am')
-rw-r--r--testsuites/ada/sptests/sp06/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/testsuites/ada/sptests/sp06/Makefile.am b/testsuites/ada/sptests/sp06/Makefile.am
new file mode 100644
index 0000000000..145423b0b4
--- /dev/null
+++ b/testsuites/ada/sptests/sp06/Makefile.am
@@ -0,0 +1,16 @@
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+
+include $(top_srcdir)/ada.am
+
+noinst_PROGRAMS = ada_sp06
+ada_sp06_SOURCES = sp06.adb config.h sptest.adb sptest.ads
+ada_sp06_SOURCES += ../../support/init.c
+
+ada_sp06$(EXEEXT): sp06.adb init.$(OBJEXT)
+ $(GNATCOMPILE) -margs -a $< -o $@
+
+scndir = $(rtems_ada_testsdir)
+dist_scn_DATA = ada_sp06.scn
+
+include $(top_srcdir)/../automake/local.am