summaryrefslogtreecommitdiffstats
path: root/doc/cpu_supplement/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/cpu_supplement/Makefile.am')
-rw-r--r--doc/cpu_supplement/Makefile.am46
1 files changed, 44 insertions, 2 deletions
diff --git a/doc/cpu_supplement/Makefile.am b/doc/cpu_supplement/Makefile.am
index 8d117cfcd0..3083922174 100644
--- a/doc/cpu_supplement/Makefile.am
+++ b/doc/cpu_supplement/Makefile.am
@@ -10,8 +10,25 @@ include $(top_srcdir)/main.am
REPLACE2 = $(PERL) $(top_srcdir)/tools/word-replace2
-GENERATED_FILES = general.texi arm.texi avr.texi bfin.texi i386.texi lm32.texi \
- m68k.texi mips.texi powerpc.texi sh.texi sparc.texi sparc64.texi v850.texi
+GENERATED_FILES =
+GENERATED_FILES += general.texi
+GENERATED_FILES += arm.texi
+GENERATED_FILES += avr.texi
+GENERATED_FILES += bfin.texi
+GENERATED_FILES += h8300.texi
+GENERATED_FILES += i386.texi
+GENERATED_FILES += lm32.texi
+GENERATED_FILES += m32c.texi
+GENERATED_FILES += m32r.texi
+GENERATED_FILES += m68k.texi
+GENERATED_FILES += microblaze.texi
+GENERATED_FILES += mips.texi
+GENERATED_FILES += powerpc.texi
+GENERATED_FILES += nios2.texi
+GENERATED_FILES += sh.texi
+GENERATED_FILES += sparc.texi
+GENERATED_FILES += sparc64.texi
+GENERATED_FILES += v850.texi
COMMON_FILES += $(top_srcdir)/common/cpright.texi
@@ -44,11 +61,26 @@ bfin.texi: bfin.t
-u "Top" \
-n "" < $< > $@
+h8300.texi: h8300.t
+ $(BMENU2) -p "" \
+ -u "Top" \
+ -n "" < $< > $@
+
i386.texi: i386.t
$(BMENU2) -p "" \
-u "Top" \
-n "" < $< > $@
+m32c.texi: m32c.t
+ $(BMENU2) -p "" \
+ -u "Top" \
+ -n "" < $< > $@
+
+m32r.texi: m32r.t
+ $(BMENU2) -p "" \
+ -u "Top" \
+ -n "" < $< > $@
+
lm32.texi: lm32.t
$(BMENU2) -p "" \
-u "Top" \
@@ -59,6 +91,11 @@ m68k.texi: m68k.t
-u "Top" \
-n "" < $< > $@
+microblaze.texi: microblaze.t
+ $(BMENU2) -p "" \
+ -u "Top" \
+ -n "" < $< > $@
+
mips.texi: mips.t
$(BMENU2) -p "" \
-u "Top" \
@@ -69,6 +106,11 @@ powerpc.texi: powerpc.t
-u "Top" \
-n "" < $< > $@
+nios2.texi: nios2.t
+ $(BMENU2) -p "" \
+ -u "Top" \
+ -n "" < $< > $@
+
sh.texi: sh.t
$(BMENU2) -p "" \
-u "Top" \