summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/powerpc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/score/cpu/powerpc/Makefile.am')
-rw-r--r--cpukit/score/cpu/powerpc/Makefile.am53
1 files changed, 22 insertions, 31 deletions
diff --git a/cpukit/score/cpu/powerpc/Makefile.am b/cpukit/score/cpu/powerpc/Makefile.am
index 376b8d0218..b866420dab 100644
--- a/cpukit/score/cpu/powerpc/Makefile.am
+++ b/cpukit/score/cpu/powerpc/Makefile.am
@@ -27,57 +27,48 @@ all-local: $(PREINSTALL_FILES)
PREINSTALL_FILES =
-$(PROJECT_INCLUDE)/$(dirstamp):
- @$(mkinstalldirs) $(PROJECT_INCLUDE)
- @: > $(PROJECT_INCLUDE)/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/$(dirstamp)
-
-$(PROJECT_INCLUDE)/asm.h: asm.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/asm.h
+$(PROJECT_INCLUDE)/asm.h: asm.h
+ $(INSTALL_DATA) $< $@
PREINSTALL_FILES += $(PROJECT_INCLUDE)/asm.h
-$(PROJECT_INCLUDE)/rtems/score/$(dirstamp):
+$(PROJECT_INCLUDE)/rtems/score:
@$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/score
- @: > $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score
-$(PROJECT_INCLUDE)/rtems/score/ppc.h: rtems/score/ppc.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/ppc.h
+$(PROJECT_INCLUDE)/rtems/score/ppc.h: rtems/score/ppc.h
+ $(INSTALL_DATA) $< $@
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/ppc.h
-$(PROJECT_INCLUDE)/rtems/score/types.h: rtems/score/types.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/types.h
+$(PROJECT_INCLUDE)/rtems/score/types.h: rtems/score/types.h
+ $(INSTALL_DATA) $< $@
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/types.h
-$(PROJECT_INCLUDE)/rtems/score/cpu.h: rtems/score/cpu.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/cpu.h
+$(PROJECT_INCLUDE)/rtems/score/cpu.h: rtems/score/cpu.h
+ $(INSTALL_DATA) $< $@
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/cpu.h
-$(PROJECT_INCLUDE)/rtems/old-exceptions/$(dirstamp):
+$(PROJECT_INCLUDE)/rtems/old-exceptions:
@$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/old-exceptions
- @: > $(PROJECT_INCLUDE)/rtems/old-exceptions/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/old-exceptions/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/old-exceptions
-$(PROJECT_INCLUDE)/rtems/old-exceptions/cpu.h: rtems/old-exceptions/cpu.h $(PROJECT_INCLUDE)/rtems/old-exceptions/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/old-exceptions/cpu.h
+$(PROJECT_INCLUDE)/rtems/old-exceptions/cpu.h: rtems/old-exceptions/cpu.h
+ $(INSTALL_DATA) $< $@
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/old-exceptions/cpu.h
-$(PROJECT_INCLUDE)/rtems/new-exceptions/$(dirstamp):
+$(PROJECT_INCLUDE)/rtems/new-exceptions:
@$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/new-exceptions
- @: > $(PROJECT_INCLUDE)/rtems/new-exceptions/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/new-exceptions/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/new-exceptions
-$(PROJECT_INCLUDE)/rtems/new-exceptions/cpu.h: rtems/new-exceptions/cpu.h $(PROJECT_INCLUDE)/rtems/new-exceptions/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/new-exceptions/cpu.h
+$(PROJECT_INCLUDE)/rtems/new-exceptions/cpu.h: rtems/new-exceptions/cpu.h
+ $(INSTALL_DATA) $< $@
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/new-exceptions/cpu.h
-$(PROJECT_INCLUDE)/rtems/powerpc/$(dirstamp):
+$(PROJECT_INCLUDE)/rtems/powerpc:
@$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/powerpc
- @: > $(PROJECT_INCLUDE)/rtems/powerpc/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/powerpc/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/powerpc
-$(PROJECT_INCLUDE)/rtems/powerpc/registers.h: rtems/powerpc/registers.h $(PROJECT_INCLUDE)/rtems/powerpc/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/powerpc/registers.h
+$(PROJECT_INCLUDE)/rtems/powerpc/registers.h: rtems/powerpc/registers.h
+ $(INSTALL_DATA) $< $@
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/powerpc/registers.h
include $(top_srcdir)/../../../automake/local.am