summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/i386/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/score/cpu/i386/Makefile.am')
-rw-r--r--cpukit/score/cpu/i386/Makefile.am24
1 files changed, 10 insertions, 14 deletions
diff --git a/cpukit/score/cpu/i386/Makefile.am b/cpukit/score/cpu/i386/Makefile.am
index 44242da27b..80ec2e6383 100644
--- a/cpukit/score/cpu/i386/Makefile.am
+++ b/cpukit/score/cpu/i386/Makefile.am
@@ -5,8 +5,7 @@
ACLOCAL_AMFLAGS = -I ../../../aclocal
include $(top_srcdir)/../../../automake/multilib.am
-include $(top_srcdir)/../../../automake/compile.am
-include $(top_srcdir)/../../../automake/lib.am
+include $(top_srcdir)/../../../automake/amcompile.am
include_HEADERS= asm.h
@@ -15,20 +14,17 @@ include_rtems_score_HEADERS = rtems/score/cpu.h rtems/score/i386.h \
rtems/score/types.h rtems/score/interrupts.h rtems/score/registers.h \
rtems/score/idtr.h
-LIB = $(ARCH)/libscorecpu.a
+EXTRA_LIBRARIES = libscorecpu.a
+CLEANFILES = libscorecpu.a
+libscorecpu_a_SOURCES = cpu.c cpu_asm.S
+libscorecpu_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
-C_FILES = cpu.c
-OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
+EXTRA_LIBRARIES += libscorecpu_g.a
+CLEANFILES += libscorecpu_g.a
+libscorecpu_g_a_SOURCES = $(libscorecpu_a_SOURCES)
+libscorecpu_g_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-S_FILES = cpu_asm.S
-OBJS += $(S_FILES:%.S=$(ARCH)/%.$(OBJEXT))
-
-$(LIB): $(OBJS)
- $(make-library)
-
-all-local: $(PREINSTALL_FILES) $(LIB)
-
-EXTRA_DIST = cpu.c cpu_asm.S
+all-local: $(PREINSTALL_FILES) libscorecpu$(LIB_VARIANT).a
PREINSTALL_FILES =