summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index 4248301cba..eb010b854b 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -147,11 +147,13 @@ endif
AM_CPPFLAGS += -D__RTEMS_INSIDE__
EXTRA_LIBRARIES = libscore.a
+CLEANFILES = libscore.a
libscore_a_SOURCES = $(C_FILES)
libscore_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
EXTRA_LIBRARIES += libscore_g.a
-libscore_g_a_SOURCES = $(C_FILES)
+CLEANFILES += libscore_g.a
+libscore_g_a_SOURCES = $(libscore_a_SOURCES)
libscore_g_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
EXTRA_DIST += $(STD_C_FILES) $(MP_C_FILES) src/Unlimited.txt