summaryrefslogtreecommitdiffstats
path: root/cpukit/sapi/inline/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/sapi/inline/Makefile.am')
-rw-r--r--cpukit/sapi/inline/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/cpukit/sapi/inline/Makefile.am b/cpukit/sapi/inline/Makefile.am
index 0c97211587..55115aa33d 100644
--- a/cpukit/sapi/inline/Makefile.am
+++ b/cpukit/sapi/inline/Makefile.am
@@ -2,9 +2,22 @@
## $Id$
##
-AUTOMAKE_OPTIONS = foreign 1.4
+AUTOMAKE_OPTIONS = foreign 1.5
-SUBDIRS = rtems
+include_rtemsdir = $(includedir)/rtems
+
+$(PROJECT_INCLUDE)/rtems:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/%: %
+ $(INSTALL_DATA) $< $@
+
+if INLINE
+include_rtems_HEADERS = rtems/extension.inl
+
+PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems \
+ $(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/%)
+endif
+
+all-local: $(PREINSTALL_FILES)
-include $(top_srcdir)/../../../automake/subdirs.am
include $(top_srcdir)/../../../automake/local.am