summaryrefslogtreecommitdiffstats
path: root/cpukit/sapi/inline/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-16 13:31:15 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-16 13:31:15 +0000
commita11e5d35cd6f1e62efdef79ce2061b6bbfe4870e (patch)
treeb64dd8865d46828e8d531e404ca6c97d5841de9f /cpukit/sapi/inline/Makefile.am
parent2001-10-16 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-a11e5d35cd6f1e62efdef79ce2061b6bbfe4870e.tar.bz2
2001-10-16 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* include/rtems/Makefile.am: Remove. * include/Makefile.am: Handle subdirs, require automake-1.5. * inline/rtems/Makefile.am: Remove. * inline/Makefile.am: Handle subdirs, require automake-1.5. * macros/rtems/Makefile.am: Remove. * Makefile.am: require automake-1.5.
Diffstat (limited to 'cpukit/sapi/inline/Makefile.am')
-rw-r--r--cpukit/sapi/inline/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/cpukit/sapi/inline/Makefile.am b/cpukit/sapi/inline/Makefile.am
index 0c97211587..55115aa33d 100644
--- a/cpukit/sapi/inline/Makefile.am
+++ b/cpukit/sapi/inline/Makefile.am
@@ -2,9 +2,22 @@
## $Id$
##
-AUTOMAKE_OPTIONS = foreign 1.4
+AUTOMAKE_OPTIONS = foreign 1.5
-SUBDIRS = rtems
+include_rtemsdir = $(includedir)/rtems
+
+$(PROJECT_INCLUDE)/rtems:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/%: %
+ $(INSTALL_DATA) $< $@
+
+if INLINE
+include_rtems_HEADERS = rtems/extension.inl
+
+PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems \
+ $(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/%)
+endif
+
+all-local: $(PREINSTALL_FILES)
-include $(top_srcdir)/../../../automake/subdirs.am
include $(top_srcdir)/../../../automake/local.am