summaryrefslogtreecommitdiffstats
path: root/cpukit/rtems/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/rtems/Makefile.am')
-rw-r--r--cpukit/rtems/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/cpukit/rtems/Makefile.am b/cpukit/rtems/Makefile.am
index fcbd8c338b..f8c17f33e7 100644
--- a/cpukit/rtems/Makefile.am
+++ b/cpukit/rtems/Makefile.am
@@ -122,15 +122,15 @@ endif
AM_CPPFLAGS += -I$(top_builddir)
AM_CPPFLAGS += -D__RTEMS_INSIDE__
-EXTRA_LIBRARIES = o-optimize/librtems.a
-o_optimize_librtems_a_SOURCES = $(C_FILES)
-o_optimize_librtems_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+EXTRA_LIBRARIES = librtems.a
+librtems_a_SOURCES = $(C_FILES)
+librtems_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
-EXTRA_LIBRARIES += o-debug/librtems.a
-o_debug_librtems_a_SOURCES = $(C_FILES)
-o_debug_librtems_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
+EXTRA_LIBRARIES += librtems_g.a
+librtems_g_a_SOURCES = $(C_FILES)
+librtems_g_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-all-local: $(PREINSTALL_FILES) $(ARCH)/librtems.a
+all-local: $(PREINSTALL_FILES) librtems$(LIB_VARIANT).a
EXTRA_DIST = $(STD_C_FILES) $(MP_C_FILES)