summaryrefslogtreecommitdiffstats
path: root/cpukit/rtems/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/rtems/Makefile.am')
-rw-r--r--cpukit/rtems/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/cpukit/rtems/Makefile.am b/cpukit/rtems/Makefile.am
index f8c17f33e7..258c0cfce4 100644
--- a/cpukit/rtems/Makefile.am
+++ b/cpukit/rtems/Makefile.am
@@ -123,11 +123,13 @@ AM_CPPFLAGS += -I$(top_builddir)
AM_CPPFLAGS += -D__RTEMS_INSIDE__
EXTRA_LIBRARIES = librtems.a
+CLEANFILES = librtems.a
librtems_a_SOURCES = $(C_FILES)
librtems_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
EXTRA_LIBRARIES += librtems_g.a
-librtems_g_a_SOURCES = $(C_FILES)
+CLEANFILES += librtems_g.a
+librtems_g_a_SOURCES = $(librtems_a_SOURCES)
librtems_g_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
all-local: $(PREINSTALL_FILES) librtems$(LIB_VARIANT).a