summaryrefslogtreecommitdiffstats
path: root/cpukit/rtems/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/rtems/Makefile.am')
-rw-r--r--cpukit/rtems/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/cpukit/rtems/Makefile.am b/cpukit/rtems/Makefile.am
index 5f2135fddb..d7835f44df 100644
--- a/cpukit/rtems/Makefile.am
+++ b/cpukit/rtems/Makefile.am
@@ -128,11 +128,12 @@ OBJS = $(C_FILES:src/%.c=${ARCH}/%.$(OBJEXT))
# Add local stuff here using +=
#
+AM_CPPFLAGS += -I$(top_builddir)
AM_CPPFLAGS += -D__RTEMS_INSIDE__
-all-local: $(PREINSTALL_FILES) $(ARCH) $(LIB)
+all-local: $(PREINSTALL_FILES) $(LIB)
-${ARCH}/%.o: src/%.c
+${ARCH}/%.o: src/%.c $(ARCH)/$(dirstamp)
${COMPILE} -o $@ -c $<
$(LIB): ${OBJS}