summaryrefslogtreecommitdiffstats
path: root/cpukit/rtems/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/rtems/Makefile.am')
-rw-r--r--cpukit/rtems/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/cpukit/rtems/Makefile.am b/cpukit/rtems/Makefile.am
index 6d61e8b8a9..2b1d46dba5 100644
--- a/cpukit/rtems/Makefile.am
+++ b/cpukit/rtems/Makefile.am
@@ -145,10 +145,9 @@ OBJS = $(C_FILES:src/%.c=${ARCH}/%.$(OBJEXT))
AM_CPPFLAGS += -D__RTEMS_INSIDE__
-all-local: ${ARCH} $(PREINSTALL_FILES) $(LIB)
+all-local: $(PREINSTALL_FILES) $(ARCH) $(LIB)
${ARCH}/%.o: src/%.c
- test -d $(ARCH) || mkdir $(ARCH)
${COMPILE} -o $@ -c $<
$(LIB): ${OBJS}