summaryrefslogtreecommitdiffstats
path: root/cpukit/librpc/src/rpc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/librpc/src/rpc/Makefile.am')
-rw-r--r--cpukit/librpc/src/rpc/Makefile.am20
1 files changed, 6 insertions, 14 deletions
diff --git a/cpukit/librpc/src/rpc/Makefile.am b/cpukit/librpc/src/rpc/Makefile.am
index a3c2157658..cd8d96cf80 100644
--- a/cpukit/librpc/src/rpc/Makefile.am
+++ b/cpukit/librpc/src/rpc/Makefile.am
@@ -2,6 +2,9 @@
## $Id$
##
+include $(top_srcdir)/../automake/multilib.am
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/lib.am
SUBDIRS = PSD.doc
@@ -23,12 +26,6 @@ C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
OBJS = $(C_O_FILES)
-include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../../../automake/compile.am
-include $(top_srcdir)/../../../automake/lib.am
-
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a
-
#
# Add local stuff here using +=
#
@@ -38,20 +35,15 @@ AM_CPPFLAGS += '-D__P(x)=x' -D_RPC_read=read -D_RPC_write=write -D_RPC_close=clo
$(LIB): $(OBJS)
$(make-library)
-$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a: $(LIB)
- $(INSTALL_DATA) $< $@
-
noinst_MANS = bindresvport.3 getrpcent.3 publickey.3 rpc.3 rpc_secure.3 \
rstat_svc.8 des_crypt.3 getrpcport.3 publickey.5 rpc.5 rstat.1 rtime.3
if HAS_NETWORKING
man_MANS = $(noinst_MANS)
-all-local: $(ARCH) $(OBJS) $(TMPINSTALL_FILES)
+all-local: $(ARCH) $(LIB)
endif
-.PRECIOUS: $(LIB)
-
EXTRA_DIST = $(C_FILES) DISCLAIMER $(UNUSED_C_FILES) $(noinst_MANS)
-include $(top_srcdir)/../../../automake/subdirs.am
-include $(top_srcdir)/../../../automake/local.am
+include $(top_srcdir)/../automake/subdirs.am
+include $(top_srcdir)/../automake/local.am