summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/libnetworking/lib/Makefile.am')
-rw-r--r--cpukit/libnetworking/lib/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/cpukit/libnetworking/lib/Makefile.am b/cpukit/libnetworking/lib/Makefile.am
new file mode 100644
index 0000000000..5f8d151e13
--- /dev/null
+++ b/cpukit/libnetworking/lib/Makefile.am
@@ -0,0 +1,33 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+LIBNAME = lib.a
+LIB = $(ARCH)/$(LIBNAME)
+
+C_FILES = getprotoby.c rtems_bsdnet_ntp.c syslog.c tftpDriver.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/lib.am
+
+#
+# Add local stuff here using +=
+#
+
+AM_CPPFLAGS += -DNOPOLL -DNOSELECT
+
+$(LIB): $(OBJS)
+ $(make-library)
+
+all-local: $(ARCH) $(OBJS) $(LIB)
+
+.PRECIOUS: $(LIB)
+
+EXTRA_DIST = README getprotoby.c rtems_bsdnet_ntp.c syslog.c tftpDriver.c
+
+include $(top_srcdir)/../../../automake/local.am