summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/libcsupport/configure.ac')
-rw-r--r--cpukit/libcsupport/configure.ac29
1 files changed, 29 insertions, 0 deletions
diff --git a/cpukit/libcsupport/configure.ac b/cpukit/libcsupport/configure.ac
index 5294b41ed1..ff33062572 100644
--- a/cpukit/libcsupport/configure.ac
+++ b/cpukit/libcsupport/configure.ac
@@ -43,6 +43,35 @@ AS_IF([test x"$RTEMS_USE_NEWLIB" != x"yes"],[
AC_CHECK_DECLS([_POSIX_LOGIN_NAME_MAX],,,[#include <limits.h>])
AC_CHECK_DECLS([CHAR_BIT],,,[#include <limits.h>])
+AS_IF([test x"${RTEMS_USE_NEWLIB}" = x"yes"],[
+ac_cv_have_decl_XTABS=yes
+ac_cv_have_decl_OLCUC=yes
+## SUSV3, but seemingly not available on some platforms (reportedly FreeBSD)
+ac_cv_have_decl_ONLRET=yes
+ac_cv_have_decl_ONOCR=yes
+ac_cv_have_decl_TABDLY=yes
+ac_cv_have_decl_OCRNL=yes
+ac_cv_have_decl_IUCLC=yes
+## SUSV3-XSI extension
+ac_cv_have_decl_ECHOPRT=yes
+])
+
+# FIXME: Some cruft to work around portability issues with termios.c
+## Seemingly not covered by any standard.
+AC_CHECK_DECLS([XTABS],,,[#include <termios.h>])
+AC_CHECK_DECLS([OLCUC],,,[#include <termios.h>])
+## SUSV3, but seemingly not available on some platforms (reportedly FreeBSD)
+AC_CHECK_DECLS([ONLRET],,,[#include <termios.h>])
+AC_CHECK_DECLS([ONOCR],,,[#include <termios.h>])
+AC_CHECK_DECLS([TABDLY],,,[#include <termios.h>])
+AC_CHECK_DECLS([OCRNL],,,[#include <termios.h>])
+AC_CHECK_DECLS([IUCLC],,,[#include <termios.h>])
+## SUSV3-XSI extension
+AC_CHECK_DECLS([ECHOPRT],,,[#include <termios.h>])
+
+## BSD-ism, excluded from POSIX, but available on most platforms
+AC_CHECK_DECLS([sbrk],,,[#include <unistd.h>])
+
AM_CONDITIONAL([NEED_SYS_CDEFS_H],[test x"$NEED_SYS_CDEFS_H" = x"yes"])
AM_CONFIG_HEADER([src/config.h])