summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/libcsupport/configure.ac')
-rw-r--r--cpukit/libcsupport/configure.ac18
1 files changed, 15 insertions, 3 deletions
diff --git a/cpukit/libcsupport/configure.ac b/cpukit/libcsupport/configure.ac
index 023b7e53bc..5378a3807c 100644
--- a/cpukit/libcsupport/configure.ac
+++ b/cpukit/libcsupport/configure.ac
@@ -26,13 +26,25 @@ RTEMS_CHECK_MULTIPROCESSING
AM_CONDITIONAL(UNIX,test x"$RTEMS_CPU" = x"unix")
AM_CONDITIONAL(NEWLIB,test x"$RTEMS_USE_NEWLIB" = x"yes")
+
AS_IF([test x"$RTEMS_USE_NEWLIB" != x"yes"],[
-# FIXME: Currently, these checks are only in here to provide
+## Provide sys/cdefs.h only if the host doesn't.
+ AC_CHECK_HEADERS([sys/cdefs.h],[NEED_SYS_CDEFS_H=no],[NEED_SYS_CDEFS_H=yes])
+# FIXME: These checks are only in here to provide
# configuration-time diagnostics and are not really used.
- AC_CHECK_HEADERS([sys/cdefs.h])
AC_CHECK_HEADERS([stdint.h inttypes.h])
- AC_CHECK_DECLS([_POSIX_LOGIN_NAME_MAX],,,[#include <limits.h>])
+],[
+## Using newlib, we provide sys/cdefs.h
+ NEED_SYS_CDEFS_H=yes
])
+
+# FIXME: These checks are only in here to provide
+# configuration-time diagnostics and are not really used.
+AC_CHECK_DECLS([_POSIX_LOGIN_NAME_MAX],,,[#include <limits.h>])
+AC_CHECK_DECLS([CHAR_BIT],,,[#include <limits.h>])
+
+AM_CONDITIONAL([NEED_SYS_CDEFS_H],[test x"$NEED_SYS_CDEFS_H" = x"yes"])
+
AM_CONFIG_HEADER(src/config.h)
# Explicitly list all Makefiles here