summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/libcsupport/configure.ac')
-rw-r--r--cpukit/libcsupport/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/cpukit/libcsupport/configure.ac b/cpukit/libcsupport/configure.ac
index d54cc2a39c..6bf9b79ebb 100644
--- a/cpukit/libcsupport/configure.ac
+++ b/cpukit/libcsupport/configure.ac
@@ -71,6 +71,9 @@ AC_CHECK_DECLS([ECHOPRT],,,[#include <termios.h>])
## BSD-ism, excluded from POSIX, but available on most platforms
AC_CHECK_DECLS([sbrk],,,[#include <unistd.h>])
+## Check if libc provides BSD's strlcpy/strlcat
+AC_CHECK_FUNCS(strlcpy strlcat)
+
AM_CONDITIONAL([NEED_SYS_CDEFS_H],[test x"$NEED_SYS_CDEFS_H" = x"yes"])
AM_CONFIG_HEADER([src/config.h])