summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/libcsupport/Makefile.am')
-rw-r--r--cpukit/libcsupport/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index 1a6e154179..177acf542d 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -56,11 +56,11 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems \
include_sysdir = $(includedir)/sys
-
if NEWLIB
-NEWLIB_H_FILES = include/sys/termios.h include/sys/cdefs.h include/sys/utsname.h
+NEWLIB_H_FILES = include/sys/termios.h include/sys/utsname.h
endif
+# FIXME: We should not install to include/sys unless using newlib.
include_sys_HEADERS = \
include/sys/filio.h \
include/sys/ioccom.h \
@@ -68,6 +68,7 @@ include/sys/ioctl.h \
include/sys/sockio.h \
include/sys/termios.h \
include/sys/ttycom.h \
+include/sys/cdefs.h \
$(NEWLIB_H_FILES)
PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys \