summaryrefslogtreecommitdiffstats
path: root/cpukit/libblock/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/libblock/Makefile.am')
-rw-r--r--cpukit/libblock/Makefile.am21
1 files changed, 9 insertions, 12 deletions
diff --git a/cpukit/libblock/Makefile.am b/cpukit/libblock/Makefile.am
index d362a1469f..d134a60b63 100644
--- a/cpukit/libblock/Makefile.am
+++ b/cpukit/libblock/Makefile.am
@@ -3,8 +3,7 @@
##
include $(top_srcdir)/automake/multilib.am
-include $(top_srcdir)/automake/compile.am
-include $(top_srcdir)/automake/lib.am
+include $(top_srcdir)/automake/amcompile.am
include_rtemsdir = $(includedir)/rtems
@@ -12,23 +11,21 @@ include_rtems_HEADERS = include/rtems/bdbuf.h include/rtems/blkdev.h \
include/rtems/diskdevs.h include/rtems/ramdisk.h \
include/rtems/ide_part_table.h
-LIB = ${ARCH}/libblock.a
-
C_FILES = src/bdbuf.c src/blkdev.c src/diskdevs.c src/ramdisk.c \
src/ide_part_table.c
-OBJS = $(C_FILES:src/%.c=${ARCH}/%.$(OBJEXT))
+EXTRA_LIBRARIES = o-optimize/libblock.a
+o_optimize_libblock_a_SOURCES = $(C_FILES)
+o_optimize_libblock_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+
+EXTRA_LIBRARIES += o-debug/libblock.a
+o_debug_libblock_a_SOURCES = $(C_FILES)
+o_debug_libblock_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
AM_CPPFLAGS += -I$(top_builddir)
AM_CPPFLAGS += $(LIBC_DEFINES)
-${ARCH}/%.$(OBJEXT): src/%.c $(ARCH)/$(dirstamp)
- ${COMPILE} -o $@ -c $<
-
-$(LIB): ${OBJS}
- $(make-library)
-
-all-local: $(PREINSTALL_FILES) $(LIB)
+all-local: $(PREINSTALL_FILES) $(ARCH)/libblock.a
PREINSTALL_FILES =