summaryrefslogtreecommitdiffstats
path: root/cpukit/itron/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/itron/src/Makefile.am')
-rw-r--r--cpukit/itron/src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/cpukit/itron/src/Makefile.am b/cpukit/itron/src/Makefile.am
index ea3ce9a24b..0c8ca41d51 100644
--- a/cpukit/itron/src/Makefile.am
+++ b/cpukit/itron/src/Makefile.am
@@ -2,6 +2,7 @@
## $Id$
##
+LIB=$(ARCH)/libitron.a
INCLUDES = -I.
@@ -52,7 +53,10 @@ include $(top_srcdir)/../automake/lib.am
AM_CPPFLAGS += -D__RTEMS_INSIDE__
-all-local: ${ARCH} ${OBJS}
+all-local: ${ARCH} ${LIB}
+
+$(LIB): ${OBJS}
+ $(make-library)
UNUSED_C_FILES = cre_mbx.c del_mbx.c mboxtranslatereturncode.c network.c \
prcv_mbx.c rcv_mbx.c ref_mbx.c snd_mbx.c sysmgmt.c trcv_mbx.c