summaryrefslogtreecommitdiffstats
path: root/cpukit/itron/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/itron/Makefile.am')
-rw-r--r--cpukit/itron/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/cpukit/itron/Makefile.am b/cpukit/itron/Makefile.am
index 7609c5dda1..4f44d64be3 100644
--- a/cpukit/itron/Makefile.am
+++ b/cpukit/itron/Makefile.am
@@ -108,13 +108,13 @@ OBJS = $(C_FILES:src/%.c=${ARCH}/%.$(OBJEXT))
AM_CPPFLAGS += -I$(top_builddir)
AM_CPPFLAGS += -D__RTEMS_INSIDE__
-all-local: $(PREINSTALL_FILES) ${ARCH} ${LIB}
+all-local: $(PREINSTALL_FILES) ${LIB}
$(LIB): ${OBJS}
$(make-library)
endif
-${ARCH}/%.$(OBJEXT): src/%.c
+${ARCH}/%.$(OBJEXT): src/%.c $(ARCH)/$(dirstamp)
${COMPILE} -o $@ -c $<
UNUSED_C_FILES = src/cre_mbx.c src/del_mbx.c src/mboxtranslatereturncode.c \