summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index d9be56702f..21763c5640 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -94,8 +94,12 @@ AC_CHECK_HEADER([inttypes.h])
AC_CHECK_HEADER([tar.h])
## if using newlib, we provide stdint.h and inttypes.h
-AM_CONDITIONAL([RTEMS_PROVIDES_STDINT_H],[test x"${RTEMS_USE_NEWLIB}" = xyes])
-AM_CONDITIONAL([RTEMS_PROVIDES_INTTYPES_H],[test x"${RTEMS_USE_NEWLIB}" = xyes])
+AM_CONDITIONAL([RTEMS_PROVIDES_STDINT_H],
+ [test x"${RTEMS_USE_NEWLIB}" = xyes \
+ && test x"${ac_cv_header_stdint_h}" = xno])
+AM_CONDITIONAL([RTEMS_PROVIDES_INTTYPES_H],
+ [test x"${RTEMS_USE_NEWLIB}" = xyes \
+ && test x"${ac_cv_header_inttypes_h}" = xno])
## if using newlib, force using stdint.h
AS_IF([test x"${RTEMS_USE_NEWLIB}" = xyes],