summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index bf01ba0f7c..cdf9915904 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -173,7 +173,7 @@ AC_CHECK_HEADER([pthread.h],[
AC_CHECK_TYPES([pthread_rwlock_t])
AC_CHECK_TYPES([pthread_barrier_t])
AC_CHECK_TYPES([pthread_spinlock_t])
- AC_CHECK_TYPES([struct _pthread_cleanup_context],[],[],[#include <pthread.h>])
+ AC_CHECK_TYPES([struct _pthread_cleanup_context],[],[AC_MSG_ERROR([struct _pthread_cleanup_context in <pthread.h> is mandatory])],[#include <pthread.h>])
])
AC_CHECK_HEADER([signal.h],[