summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index d04ce87efd..69319ad65f 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -17,6 +17,7 @@ RTEMS_ENABLE_RTEMS_DEBUG
RTEMS_ENABLE_NETWORKING
RTEMS_ENABLE_PARAVIRT
RTEMS_ENABLE_PROFILING
+RTEMS_ENABLE_DRVMGR
RTEMS_ENV_RTEMSCPU
RTEMS_CHECK_RTEMS_DEBUG
@@ -229,6 +230,11 @@ RTEMS_CPUOPT([RTEMS_NETWORKING],
[1],
[if networking is enabled])
+RTEMS_CPUOPT([RTEMS_DRVMGR_STARTUP],
+ [test x"$enable_drvmgr" = xyes],
+ [1],
+ [if driver manager api is supported])
+
RTEMS_CPUOPT([RTEMS_VERSION],
[true],
["]_RTEMS_VERSION["],
@@ -453,6 +459,7 @@ score/cpu/v850/Makefile
score/cpu/no_cpu/Makefile
posix/Makefile
libblock/Makefile
+libdrvmgr/Makefile
libfs/Makefile
libfs/src/nfsclient/Makefile
libgnat/Makefile