summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac18
1 files changed, 1 insertions, 17 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 5611088853..9d72d96095 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -227,23 +227,7 @@ AC_COMPILE_IFELSE(
AC_MSG_RESULT([$HAVE_ASSIGNABLE_STDIO])
# libmisc/serdbg exploits weak symbols
-AC_CACHE_CHECK([whether $CC supports function __attribute__((weak))],
-[rtems_cv_cc_attribute_weak],[
- AS_IF([test x"$GCC" = xyes],[
- save_CFLAGS=$CFLAGS
- CFLAGS=-Werror])
-
- AC_COMPILE_IFELSE([
- AC_LANG_PROGRAM(
- [void myfunc(char c) __attribute__ ((weak));
- void myfunc(char c) {}],
- [])],
- [rtems_cv_cc_attribute_weak=yes],
- [rtems_cv_cc_attribute_weak=no])
-
- AS_IF([test x"$GCC" = xyes],[
- CFLAGS=$save_CFLAGS])
-])
+RTEMS_CHECK_GCC_WEAK
AC_CHECK_HEADERS([sys/cdefs.h],[NEED_SYS_CDEFS_H=no],[NEED_SYS_CDEFS_H=yes])
AC_CHECK_HEADERS([sys/queue.h],[NEED_SYS_QUEUE_H=no],[NEED_SYS_QUEUE_H=yes])