summaryrefslogtreecommitdiffstats
path: root/cpukit/ada/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/ada/Makefile.am')
-rw-r--r--cpukit/ada/Makefile.am35
1 files changed, 25 insertions, 10 deletions
diff --git a/cpukit/ada/Makefile.am b/cpukit/ada/Makefile.am
index 635f636352..4b2a807b16 100644
--- a/cpukit/ada/Makefile.am
+++ b/cpukit/ada/Makefile.am
@@ -2,23 +2,38 @@
# $Id$
#
-$(PROJECT_INCLUDE)/adainclude:
- $(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/adainclude/%: %
- $(INSTALL_DATA) $< $@
-
adaincludedir = $(includedir)/adainclude
if RTEMS_ADA
adainclude_HEADERS = rtems.adb rtems.ads
adainclude_HEADERS += rtems-multiprocessing.adb rtems-multiprocessing.ads
-
-TMPINSTALL_FILES = \
- $(PROJECT_INCLUDE)/adainclude \
- $(adainclude_HEADERS:%=$(PROJECT_INCLUDE)/adainclude/%) \
- $(nodist_adalib_HEADERS:%=$(PROJECT_INCLUDE)/adainclude/%)
endif
all-local: $(TMPINSTALL_FILES)
+PREINSTALL_FILES =
+
+$(PROJECT_INCLUDE)/adainclude/$(dirstamp):
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/adainclude
+ @: > $(PROJECT_INCLUDE)/adainclude/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/adainclude/$(dirstamp)
+
+if RTEMS_ADA
+$(PROJECT_INCLUDE)/adainclude/rtems.adb: rtems.adb $(PROJECT_INCLUDE)/adainclude/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/adainclude/rtems.adb
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/adainclude/rtems.adb
+
+$(PROJECT_INCLUDE)/adainclude/rtems.ads: rtems.ads $(PROJECT_INCLUDE)/adainclude/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/adainclude/rtems.ads
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/adainclude/rtems.ads
+
+$(PROJECT_INCLUDE)/adainclude/rtems-multiprocessing.adb: rtems-multiprocessing.adb $(PROJECT_INCLUDE)/adainclude/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/adainclude/rtems-multiprocessing.adb
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/adainclude/rtems-multiprocessing.adb
+
+$(PROJECT_INCLUDE)/adainclude/rtems-multiprocessing.ads: rtems-multiprocessing.ads $(PROJECT_INCLUDE)/adainclude/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/adainclude/rtems-multiprocessing.ads
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/adainclude/rtems-multiprocessing.ads
+endif
+
include $(top_srcdir)/automake/local.am