summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am21
1 files changed, 20 insertions, 1 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index bf8b2c2206..35b47e4b54 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -343,7 +343,6 @@ _SUBDIRS += libmd
_SUBDIRS += libgnat
_SUBDIRS += libdl
_SUBDIRS += libstdthreads
-_SUBDIRS += libdebugger
_SUBDIRS += wrapup
# other libraries
@@ -362,6 +361,26 @@ libftpd_a_SOURCES =
libftpd_a_SOURCES += ftpd/ftpd.c
libftpd_a_SOURCES += ftpd/ftpd-init.c
+if LIBDEBUGGER
+
+project_lib_LIBRARIES += libdebugger.a
+
+$(PROJECT_LIB)/libdebugger.a: libdebugger.a
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/libdebugger.a
+TMPINSTALL_FILES += $(PROJECT_LIB)/libdebugger.a
+
+libdebugger_a_SOURCES =
+libdebugger_a_SOURCES += libdebugger/rtems-debugger-block.c
+libdebugger_a_SOURCES += libdebugger/rtems-debugger-cmd.c
+libdebugger_a_SOURCES += libdebugger/rtems-debugger-remote.c
+libdebugger_a_SOURCES += libdebugger/rtems-debugger-remote-tcp.c
+libdebugger_a_SOURCES += libdebugger/rtems-debugger-@RTEMS_CPU@.c
+libdebugger_a_SOURCES += libdebugger/rtems-debugger-server.c
+libdebugger_a_SOURCES += libdebugger/rtems-debugger-target.c
+libdebugger_a_SOURCES += libdebugger/rtems-debugger-threads.c
+
+endif
+
include $(top_srcdir)/automake/subdirs.am
include $(top_srcdir)/automake/local.am
include $(srcdir)/headers.am