summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am223
1 files changed, 222 insertions, 1 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 9e02e37959..e6b7ec0de5 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -368,6 +368,122 @@ libcpukit_a_SOURCES += libstdthreads/call_once.c
libcpukit_a_SOURCES += libstdthreads/cnd.c
libcpukit_a_SOURCES += libstdthreads/mtx.c
libcpukit_a_SOURCES += libstdthreads/tss.c
+libcpukit_a_SOURCES += posix/src/nanosleep.c
+libcpukit_a_SOURCES += posix/src/clockgettime.c
+libcpukit_a_SOURCES += posix/src/clocksettime.c
+libcpukit_a_SOURCES += posix/src/clockgetres.c
+libcpukit_a_SOURCES += posix/src/sysconf.c
+libcpukit_a_SOURCES += posix/src/fork.c
+libcpukit_a_SOURCES += posix/src/vfork.c
+libcpukit_a_SOURCES += posix/src/wait.c
+libcpukit_a_SOURCES += posix/src/waitpid.c
+libcpukit_a_SOURCES += posix/src/pthreadgetnamenp.c
+libcpukit_a_SOURCES += posix/src/pthreadsetnamenp.c
+libcpukit_a_SOURCES += posix/src/barrierattrdestroy.c
+libcpukit_a_SOURCES += posix/src/barrierattrgetpshared.c
+libcpukit_a_SOURCES += posix/src/barrierattrinit.c
+libcpukit_a_SOURCES += posix/src/barrierattrsetpshared.c
+libcpukit_a_SOURCES += posix/src/pbarrierdestroy.c
+libcpukit_a_SOURCES += posix/src/pbarrierinit.c
+libcpukit_a_SOURCES += posix/src/pbarrierwait.c
+libcpukit_a_SOURCES += posix/src/condattrdestroy.c
+libcpukit_a_SOURCES += posix/src/condattrinit.c
+libcpukit_a_SOURCES += posix/src/condattrgetpshared.c
+libcpukit_a_SOURCES += posix/src/condattrsetpshared.c
+libcpukit_a_SOURCES += posix/src/condattrgetclock.c
+libcpukit_a_SOURCES += posix/src/condattrsetclock.c
+libcpukit_a_SOURCES += posix/src/condbroadcast.c
+libcpukit_a_SOURCES += posix/src/conddefaultattributes.c
+libcpukit_a_SOURCES += posix/src/conddestroy.c
+libcpukit_a_SOURCES += posix/src/condinit.c
+libcpukit_a_SOURCES += posix/src/condsignal.c
+libcpukit_a_SOURCES += posix/src/condsignalsupp.c
+libcpukit_a_SOURCES += posix/src/condtimedwait.c
+libcpukit_a_SOURCES += posix/src/condwait.c
+libcpukit_a_SOURCES += posix/src/condwaitsupp.c
+libcpukit_a_SOURCES += posix/src/mutexattrdestroy.c
+libcpukit_a_SOURCES += posix/src/mutexattrgetprioceiling.c
+libcpukit_a_SOURCES += posix/src/mutexattrgetprotocol.c
+libcpukit_a_SOURCES += posix/src/mutexattrgetpshared.c
+libcpukit_a_SOURCES += posix/src/mutexattrgettype.c
+libcpukit_a_SOURCES += posix/src/mutexattrinit.c
+libcpukit_a_SOURCES += posix/src/mutexattrsetprioceiling.c
+libcpukit_a_SOURCES += posix/src/mutexattrsetprotocol.c
+libcpukit_a_SOURCES += posix/src/mutexattrsetpshared.c
+libcpukit_a_SOURCES += posix/src/mutexattrsettype.c
+libcpukit_a_SOURCES += posix/src/mutexdestroy.c
+libcpukit_a_SOURCES += posix/src/mutexgetprioceiling.c
+libcpukit_a_SOURCES += posix/src/mutexinit.c
+libcpukit_a_SOURCES += posix/src/mutexlock.c
+libcpukit_a_SOURCES += posix/src/mutexlocksupp.c
+libcpukit_a_SOURCES += posix/src/mutexsetprioceiling.c
+libcpukit_a_SOURCES += posix/src/mutextimedlock.c
+libcpukit_a_SOURCES += posix/src/mutextrylock.c
+libcpukit_a_SOURCES += posix/src/mutexunlock.c
+libcpukit_a_SOURCES += posix/src/psxpriorityisvalid.c
+libcpukit_a_SOURCES += posix/src/pthreadattrdefault.c
+libcpukit_a_SOURCES += posix/src/pthreadattrdestroy.c
+libcpukit_a_SOURCES += posix/src/pthreadattrgetdetachstate.c
+libcpukit_a_SOURCES += posix/src/pthreadattrgetguardsize.c
+libcpukit_a_SOURCES += posix/src/pthreadattrgetinheritsched.c
+libcpukit_a_SOURCES += posix/src/pthreadattrgetschedparam.c
+libcpukit_a_SOURCES += posix/src/pthreadattrgetschedpolicy.c
+libcpukit_a_SOURCES += posix/src/pthreadattrgetscope.c
+libcpukit_a_SOURCES += posix/src/pthreadattrgetstackaddr.c
+libcpukit_a_SOURCES += posix/src/pthreadattrgetstack.c
+libcpukit_a_SOURCES += posix/src/pthreadattrgetstacksize.c
+libcpukit_a_SOURCES += posix/src/pthreadattrinit.c
+libcpukit_a_SOURCES += posix/src/pthreadattrsetdetachstate.c
+libcpukit_a_SOURCES += posix/src/pthreadattrsetguardsize.c
+libcpukit_a_SOURCES += posix/src/pthreadattrsetinheritsched.c
+libcpukit_a_SOURCES += posix/src/pthreadattrsetschedparam.c
+libcpukit_a_SOURCES += posix/src/pthreadattrsetschedpolicy.c
+libcpukit_a_SOURCES += posix/src/pthreadattrsetscope.c
+libcpukit_a_SOURCES += posix/src/pthreadattrsetstackaddr.c
+libcpukit_a_SOURCES += posix/src/pthreadattrsetstack.c
+libcpukit_a_SOURCES += posix/src/pthreadattrsetstacksize.c
+libcpukit_a_SOURCES += posix/src/pthreadattrsetaffinitynp.c
+libcpukit_a_SOURCES += posix/src/pthreadattrgetaffinitynp.c
+libcpukit_a_SOURCES += posix/src/pthreadgetaffinitynp.c
+libcpukit_a_SOURCES += posix/src/pthreadsetaffinitynp.c
+libcpukit_a_SOURCES += posix/src/key.c
+libcpukit_a_SOURCES += posix/src/keycreate.c
+libcpukit_a_SOURCES += posix/src/keydelete.c
+libcpukit_a_SOURCES += posix/src/keygetspecific.c
+libcpukit_a_SOURCES += posix/src/keysetspecific.c
+libcpukit_a_SOURCES += posix/src/pthreadonce.c
+libcpukit_a_SOURCES += posix/src/sigaddset.c
+libcpukit_a_SOURCES += posix/src/sigdelset.c
+libcpukit_a_SOURCES += posix/src/sigfillset.c
+libcpukit_a_SOURCES += posix/src/sigemptyset.c
+libcpukit_a_SOURCES += posix/src/sigismember.c
+libcpukit_a_SOURCES += posix/src/sigprocmask.c
+libcpukit_a_SOURCES += posix/src/pspindestroy.c
+libcpukit_a_SOURCES += posix/src/pspininit.c
+libcpukit_a_SOURCES += posix/src/pspinlock.c
+libcpukit_a_SOURCES += posix/src/pspinunlock.c
+libcpukit_a_SOURCES += posix/src/semdestroy.c
+libcpukit_a_SOURCES += posix/src/semgetvalue.c
+libcpukit_a_SOURCES += posix/src/seminit.c
+libcpukit_a_SOURCES += posix/src/sempost.c
+libcpukit_a_SOURCES += posix/src/semtimedwait.c
+libcpukit_a_SOURCES += posix/src/semtrywait.c
+libcpukit_a_SOURCES += posix/src/semwait.c
+libcpukit_a_SOURCES += posix/src/prwlockdestroy.c
+libcpukit_a_SOURCES += posix/src/prwlockinit.c
+libcpukit_a_SOURCES += posix/src/prwlockrdlock.c
+libcpukit_a_SOURCES += posix/src/prwlocktimedrdlock.c
+libcpukit_a_SOURCES += posix/src/prwlocktimedwrlock.c
+libcpukit_a_SOURCES += posix/src/prwlocktryrdlock.c
+libcpukit_a_SOURCES += posix/src/prwlocktrywrlock.c
+libcpukit_a_SOURCES += posix/src/prwlockunlock.c
+libcpukit_a_SOURCES += posix/src/prwlockwrlock.c
+libcpukit_a_SOURCES += posix/src/rwlockattrdestroy.c
+libcpukit_a_SOURCES += posix/src/rwlockattrgetpshared.c
+libcpukit_a_SOURCES += posix/src/rwlockattrinit.c
+libcpukit_a_SOURCES += posix/src/rwlockattrsetpshared.c
+libcpukit_a_SOURCES += posix/src/sched_getprioritymin.c
+libcpukit_a_SOURCES += posix/src/sched_getprioritymax.c
libcpukit_a_SOURCES += sapi/src/chainappendnotify.c
libcpukit_a_SOURCES += sapi/src/chaingetnotify.c
libcpukit_a_SOURCES += sapi/src/chaingetwait.c
@@ -409,6 +525,111 @@ libcpukit_a_SOURCES += sapi/src/version.c
if HAS_PTHREADS
libcpukit_a_SOURCES += libstdthreads/thrd.c
+libcpukit_a_SOURCES += posix/src/adjtime.c
+libcpukit_a_SOURCES += posix/src/aio_cancel.c
+libcpukit_a_SOURCES += posix/src/aio_error.c
+libcpukit_a_SOURCES += posix/src/aio_fsync.c
+libcpukit_a_SOURCES += posix/src/aio_misc.c
+libcpukit_a_SOURCES += posix/src/aio_read.c
+libcpukit_a_SOURCES += posix/src/aio_return.c
+libcpukit_a_SOURCES += posix/src/aio_suspend.c
+libcpukit_a_SOURCES += posix/src/aio_write.c
+libcpukit_a_SOURCES += posix/src/alarm.c
+libcpukit_a_SOURCES += posix/src/cancel.c
+libcpukit_a_SOURCES += posix/src/cleanuppush.c
+libcpukit_a_SOURCES += posix/src/clockgetcpuclockid.c
+libcpukit_a_SOURCES += posix/src/_execve.c
+libcpukit_a_SOURCES += posix/src/getitimer.c
+libcpukit_a_SOURCES += posix/src/kill.c
+libcpukit_a_SOURCES += posix/src/killinfo.c
+libcpukit_a_SOURCES += posix/src/kill_r.c
+libcpukit_a_SOURCES += posix/src/lio_listio.c
+libcpukit_a_SOURCES += posix/src/mlockall.c
+libcpukit_a_SOURCES += posix/src/mlock.c
+libcpukit_a_SOURCES += posix/src/mmap.c
+libcpukit_a_SOURCES += posix/src/mprotect.c
+libcpukit_a_SOURCES += posix/src/mqueue.c
+libcpukit_a_SOURCES += posix/src/mqueueclose.c
+libcpukit_a_SOURCES += posix/src/mqueuedeletesupp.c
+libcpukit_a_SOURCES += posix/src/mqueuegetattr.c
+libcpukit_a_SOURCES += posix/src/mqueuenotify.c
+libcpukit_a_SOURCES += posix/src/mqueueopen.c
+libcpukit_a_SOURCES += posix/src/mqueuereceive.c
+libcpukit_a_SOURCES += posix/src/mqueuerecvsupp.c
+libcpukit_a_SOURCES += posix/src/mqueuesend.c
+libcpukit_a_SOURCES += posix/src/mqueuesendsupp.c
+libcpukit_a_SOURCES += posix/src/mqueuesetattr.c
+libcpukit_a_SOURCES += posix/src/mqueuetimedreceive.c
+libcpukit_a_SOURCES += posix/src/mqueuetimedsend.c
+libcpukit_a_SOURCES += posix/src/mqueueunlink.c
+libcpukit_a_SOURCES += posix/src/msync.c
+libcpukit_a_SOURCES += posix/src/munlockall.c
+libcpukit_a_SOURCES += posix/src/munlock.c
+libcpukit_a_SOURCES += posix/src/munmap.c
+libcpukit_a_SOURCES += posix/src/pause.c
+libcpukit_a_SOURCES += posix/src/posix_madvise.c
+libcpukit_a_SOURCES += posix/src/psignal.c
+libcpukit_a_SOURCES += posix/src/psignalclearprocesssignals.c
+libcpukit_a_SOURCES += posix/src/psignalclearsignals.c
+libcpukit_a_SOURCES += posix/src/psignalsetprocesssignals.c
+libcpukit_a_SOURCES += posix/src/psignalunblockthread.c
+libcpukit_a_SOURCES += posix/src/psxnametoid.c
+libcpukit_a_SOURCES += posix/src/psxpriorityisvalid.c
+libcpukit_a_SOURCES += posix/src/psxsemaphore.c
+libcpukit_a_SOURCES += posix/src/psxtimercreate.c
+libcpukit_a_SOURCES += posix/src/psxtimerdelete.c
+libcpukit_a_SOURCES += posix/src/psxtransschedparam.c
+libcpukit_a_SOURCES += posix/src/pthreadatfork.c
+libcpukit_a_SOURCES += posix/src/pthread.c
+libcpukit_a_SOURCES += posix/src/pthreadconcurrency.c
+libcpukit_a_SOURCES += posix/src/pthreadcreate.c
+libcpukit_a_SOURCES += posix/src/pthreaddetach.c
+libcpukit_a_SOURCES += posix/src/pthreadequal.c
+libcpukit_a_SOURCES += posix/src/pthreadexit.c
+libcpukit_a_SOURCES += posix/src/pthreadgetattrnp.c
+libcpukit_a_SOURCES += posix/src/pthreadgetcpuclockid.c
+libcpukit_a_SOURCES += posix/src/pthreadgetschedparam.c
+libcpukit_a_SOURCES += posix/src/pthreadinitthreads.c
+libcpukit_a_SOURCES += posix/src/pthreadjoin.c
+libcpukit_a_SOURCES += posix/src/pthreadkill.c
+libcpukit_a_SOURCES += posix/src/pthreadkill.c
+libcpukit_a_SOURCES += posix/src/pthreadself.c
+libcpukit_a_SOURCES += posix/src/pthreadsetschedparam.c
+libcpukit_a_SOURCES += posix/src/pthreadsetschedprio.c
+libcpukit_a_SOURCES += posix/src/pthreadsigmask.c
+libcpukit_a_SOURCES += posix/src/pthreadsigmask.c
+libcpukit_a_SOURCES += posix/src/ptimer.c
+libcpukit_a_SOURCES += posix/src/sched_getparam.c
+libcpukit_a_SOURCES += posix/src/sched_getscheduler.c
+libcpukit_a_SOURCES += posix/src/sched_rr_get_interval.c
+libcpukit_a_SOURCES += posix/src/sched_setparam.c
+libcpukit_a_SOURCES += posix/src/sched_setscheduler.c
+libcpukit_a_SOURCES += posix/src/sched_yield.c
+libcpukit_a_SOURCES += posix/src/semaphoredeletesupp.c
+libcpukit_a_SOURCES += posix/src/semclose.c
+libcpukit_a_SOURCES += posix/src/semopen.c
+libcpukit_a_SOURCES += posix/src/semunlink.c
+libcpukit_a_SOURCES += posix/src/setcancelstate.c
+libcpukit_a_SOURCES += posix/src/setcanceltype.c
+libcpukit_a_SOURCES += posix/src/setitimer.c
+libcpukit_a_SOURCES += posix/src/shm.c
+libcpukit_a_SOURCES += posix/src/shmheap.c
+libcpukit_a_SOURCES += posix/src/shmopen.c
+libcpukit_a_SOURCES += posix/src/shmunlink.c
+libcpukit_a_SOURCES += posix/src/shmwkspace.c
+libcpukit_a_SOURCES += posix/src/sigaction.c
+libcpukit_a_SOURCES += posix/src/signal_2.c
+libcpukit_a_SOURCES += posix/src/sigpending.c
+libcpukit_a_SOURCES += posix/src/sigqueue.c
+libcpukit_a_SOURCES += posix/src/sigsuspend.c
+libcpukit_a_SOURCES += posix/src/sigtimedwait.c
+libcpukit_a_SOURCES += posix/src/sigwait.c
+libcpukit_a_SOURCES += posix/src/sigwaitinfo.c
+libcpukit_a_SOURCES += posix/src/testcancel.c
+libcpukit_a_SOURCES += posix/src/timergetoverrun.c
+libcpukit_a_SOURCES += posix/src/timergettime.c
+libcpukit_a_SOURCES += posix/src/timersettime.c
+libcpukit_a_SOURCES += posix/src/ualarm.c
endif
@@ -615,7 +836,7 @@ $(top_srcdir)/sapi/src/version.c: version-vc-key.h
all-local: generate-vc-key
# librtemscpu
-_SUBDIRS = . score rtems posix
+_SUBDIRS = . score rtems
_SUBDIRS += libnetworking
_SUBDIRS += libmisc
_SUBDIRS += wrapup