summaryrefslogtreecommitdiffstats
path: root/contrib/crossrpms/rtems4.9/m68k/rtems-4.9-m68k-rtems4.9-gdb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/crossrpms/rtems4.9/m68k/rtems-4.9-m68k-rtems4.9-gdb.spec')
-rw-r--r--contrib/crossrpms/rtems4.9/m68k/rtems-4.9-m68k-rtems4.9-gdb.spec45
1 files changed, 31 insertions, 14 deletions
diff --git a/contrib/crossrpms/rtems4.9/m68k/rtems-4.9-m68k-rtems4.9-gdb.spec b/contrib/crossrpms/rtems4.9/m68k/rtems-4.9-m68k-rtems4.9-gdb.spec
index 759fea57a5..9dbf76030a 100644
--- a/contrib/crossrpms/rtems4.9/m68k/rtems-4.9-m68k-rtems4.9-gdb.spec
+++ b/contrib/crossrpms/rtems4.9/m68k/rtems-4.9-m68k-rtems4.9-gdb.spec
@@ -19,21 +19,25 @@
%define debug_package %{nil}
%endif
-%define gdb_version 6.7.1
-%define gdb_rpmvers %{expand:%(echo 6.7.1 | tr - _)}
+%if "%{_build}" != "%{_host}"
+%define _host_rpmprefix rtems-4.9-%{_host}-
+%else
+%define _host_rpmprefix %{nil}
+%endif
+
+%define gdb_version 6.8
+%define gdb_rpmvers %{expand:%(echo 6.8 | tr - _)}
Name: rtems-4.9-m68k-rtems4.9-gdb
Summary: Gdb for target m68k-rtems4.9
Group: Development/Tools
Version: %{gdb_rpmvers}
-Release: 6%{?dist}
+Release: 2%{?dist}
License: GPL/LGPL
URL: http://sources.redhat.com/gdb
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-%if "%{_build}" != "%{_host}"
-BuildRequires: rtems-4.9-%{_host}-gcc
-%endif
+BuildRequires: %{_host_rpmprefix}gcc
%if "%{gdb_version}" >= "6.6"
# suse
@@ -44,26 +48,33 @@ BuildRequires: libexpat-devel
BuildRequires: expat
%endif
%else
-# fedora/redhat
-BuildRequires: expat-devel
+# fedora/redhat/cygwin
+BuildRequires: %{_host_rpmprefix}expat-devel
+%endif
+%endif
+
+%if "%{gdb_version}" < "6.6"
+%if "%{_build}" != "%{_host}"
+BuildRequires: %{_host_rpmprefix}termcap-devel
%endif
%endif
+BuildRequires: %{_host_rpmprefix}readline-devel
+BuildRequires: %{_host_rpmprefix}ncurses-devel
+
# Required for building the infos
BuildRequires: /sbin/install-info
BuildRequires: texinfo >= 4.2
%if "m68k-rtems4.9" == "sparc-rtems4.9"
BuildConflicts: libtermcap-devel termcap-devel
%endif
-BuildRequires: readline-devel
-BuildRequires: ncurses-devel
+
Requires: rtems-4.9-gdb-common
Source0: ftp://ftp.gnu.org/pub/gnu/gdb/gdb-%{gdb_version}.tar.bz2
%{?_without_sources:NoSource: 0}
-%if "%{gdb_version}" == "6.7.1"
-Patch0: gdb-6.7.1-rtems4.9-20080324.diff
-Patch1: gdb-6.7.1-gdb-6.7.90-config.diff
+%if "%{gdb_version}" == "6.8"
+Patch0: gdb-6.8-rtems4.9-20080428.diff
%endif
%description
@@ -77,10 +88,17 @@ cd gdb-%{gdb_version}
%{?PATCH1:%patch1 -p1}
cd ..
+%if "%{gdb_version}" >= "6.8"
+# Force using a system-provided libreadline
+rm -f gdb-%{gdb_version}/readline/configure
+%endif
%build
export PATH="%{_bindir}:${PATH}"
mkdir -p build
cd build
+%if "%{_build}" != "%{_host}"
+ CFLAGS_FOR_BUILD="-g -O2 -Wall" \
+%endif
CFLAGS="$RPM_OPT_FLAGS" \
../gdb-%{gdb_version}/configure \
--build=%_build --host=%_host \
@@ -167,7 +185,6 @@ sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
# %endif
%description -n rtems-4.9-m68k-rtems4.9-gdb
-
GNU gdb targetting m68k-rtems4.9.
%files -n rtems-4.9-m68k-rtems4.9-gdb