summaryrefslogtreecommitdiffstats
path: root/contrib/crossrpms/rtems4.11/powerpc/rtems-4.11-powerpc-rtems4.11-gdb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/crossrpms/rtems4.11/powerpc/rtems-4.11-powerpc-rtems4.11-gdb.spec')
-rw-r--r--contrib/crossrpms/rtems4.11/powerpc/rtems-4.11-powerpc-rtems4.11-gdb.spec50
1 files changed, 22 insertions, 28 deletions
diff --git a/contrib/crossrpms/rtems4.11/powerpc/rtems-4.11-powerpc-rtems4.11-gdb.spec b/contrib/crossrpms/rtems4.11/powerpc/rtems-4.11-powerpc-rtems4.11-gdb.spec
index 04ed2adbb1..fd6d25c661 100644
--- a/contrib/crossrpms/rtems4.11/powerpc/rtems-4.11-powerpc-rtems4.11-gdb.spec
+++ b/contrib/crossrpms/rtems4.11/powerpc/rtems-4.11-powerpc-rtems4.11-gdb.spec
@@ -61,6 +61,27 @@ BuildRequires: %{_host_rpmprefix}gcc
%define build_sim --enable-sim
+# Whether to build against system readline
+# Default: yes
+%bcond_without system_readline
+
+# Whether to build python support
+%if "%{_build}" != "%{_host}"
+# Can't build python Cdn-X
+%bcond_with python
+%else
+%if "%{gdb_version}" >= "7.3"
+# Python support is broken
+%bcond_with python
+%elseif "%{gdb_version}" >= "6.8.50"
+%bcond_without python
+%else
+# python is unsupported
+%bcond_with python
+%endif
+%endif
+%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
+
%if "%{_build}" != "%{_host}"
# psim doesn't support Cdn-X
%define build_sim --disable-sim
@@ -68,7 +89,6 @@ BuildRequires: %{_host_rpmprefix}gcc
%define build_sim --enable-sim --enable-sim-trace
%endif
-%if "%{gdb_version}" >= "6.6"
# suse
%if "%{?suse}" >= "10.3"
BuildRequires: libexpat-devel
@@ -76,28 +96,10 @@ BuildRequires: libexpat-devel
# Fedora/CentOS/Cygwin/MinGW
BuildRequires: %{_host_rpmprefix}expat-devel
%endif
-%endif
-%if "%{gdb_version}" < "6.7"
-%if "%{_build}" != "%{_host}"
-BuildRequires: %{_host_rpmprefix}termcap-devel
-%endif
-%bcond_with system_readline
-%else
-%bcond_without system_readline
-%endif
%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
BuildRequires: %{_host_rpmprefix}ncurses-devel
-%if "%{gdb_version}" >= "6.8.50"
-%if "%{_build}" != "%{_host}"
-# Can't build python Cdn-X
-%bcond_with python
-%else
-%bcond_without python
-%endif
-%endif
-%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
# Required for building the infos
BuildRequires: /sbin/install-info
@@ -144,16 +146,8 @@ cd ..
--disable-werror \
%{build_sim} \
%{?with_system_readline:--with-system-readline} \
-%if "%{gdb_version}" >= "6.6"
--with-expat \
-%endif
-%if "%{gdb_version}" >= "6.8.50"
-%if %{with python}
- --with-python \
-%else
- --without-python \
-%endif
-%endif
+ %{?with_python:--with-python}%{!?with_python:--without-python} \
--prefix=%{_prefix} --bindir=%{_bindir} \
--includedir=%{_includedir} --libdir=%{_libdir} \
--mandir=%{_mandir} --infodir=%{_infodir}