summaryrefslogtreecommitdiffstats
path: root/contrib/crossrpms/rtems4.11/h8300/rtems-4.11-h8300-rtems4.11-gdb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/crossrpms/rtems4.11/h8300/rtems-4.11-h8300-rtems4.11-gdb.spec')
-rw-r--r--contrib/crossrpms/rtems4.11/h8300/rtems-4.11-h8300-rtems4.11-gdb.spec54
1 files changed, 24 insertions, 30 deletions
diff --git a/contrib/crossrpms/rtems4.11/h8300/rtems-4.11-h8300-rtems4.11-gdb.spec b/contrib/crossrpms/rtems4.11/h8300/rtems-4.11-h8300-rtems4.11-gdb.spec
index 0734e2db70..d344f98c4a 100644
--- a/contrib/crossrpms/rtems4.11/h8300/rtems-4.11-h8300-rtems4.11-gdb.spec
+++ b/contrib/crossrpms/rtems4.11/h8300/rtems-4.11-h8300-rtems4.11-gdb.spec
@@ -52,7 +52,7 @@ Name: rtems-4.11-h8300-rtems4.11-gdb
Summary: Gdb for target h8300-rtems4.11
Group: Development/Tools
Version: %{gdb_rpmvers}
-Release: 1%{?dist}
+Release: 2%{?dist}
License: GPL/LGPL
URL: http://sources.redhat.com/gdb
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -61,12 +61,32 @@ BuildRequires: %{_host_rpmprefix}gcc
%define build_sim --enable-sim
+# Whether to build against system readline
+# Default: yes
+%bcond_without system_readline
+
+# Whether to build python support
+%if "%{_build}" != "%{_host}"
+# Can't build python Cdn-X
+%bcond_with python
+%else
+%if "%{gdb_version}" >= "7.3"
+# Python support is broken
+%bcond_with python
+%elseif "%{gdb_version}" >= "6.8.50"
+%bcond_without python
+%else
+# python is unsupported
+%bcond_with python
+%endif
+%endif
+%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
+
%ifos mingw mingw32
# Mingw lacks functions required by the h8300 simulator
%define build_sim --disable-sim
%endif
-%if "%{gdb_version}" >= "6.6"
# suse
%if "%{?suse}" >= "10.3"
BuildRequires: libexpat-devel
@@ -74,28 +94,10 @@ BuildRequires: libexpat-devel
# Fedora/CentOS/Cygwin/MinGW
BuildRequires: %{_host_rpmprefix}expat-devel
%endif
-%endif
-%if "%{gdb_version}" < "6.7"
-%if "%{_build}" != "%{_host}"
-BuildRequires: %{_host_rpmprefix}termcap-devel
-%endif
-%bcond_with system_readline
-%else
-%bcond_without system_readline
-%endif
%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
BuildRequires: %{_host_rpmprefix}ncurses-devel
-%if "%{gdb_version}" >= "6.8.50"
-%if "%{_build}" != "%{_host}"
-# Can't build python Cdn-X
-%bcond_with python
-%else
-%bcond_without python
-%endif
-%endif
-%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
# Required for building the infos
BuildRequires: /sbin/install-info
@@ -106,7 +108,7 @@ Requires: rtems-4.11-gdb-common
%if "%{gdb_version}" == "7.2"
Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.2.tar.bz2
-Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100903.diff
+Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100907.diff
%endif
%if "%{gdb_version}" == "7.1"
Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.1.tar.bz2
@@ -142,16 +144,8 @@ cd ..
--disable-werror \
%{build_sim} \
%{?with_system_readline:--with-system-readline} \
-%if "%{gdb_version}" >= "6.6"
--with-expat \
-%endif
-%if "%{gdb_version}" >= "6.8.50"
-%if %{with python}
- --with-python \
-%else
- --without-python \
-%endif
-%endif
+ %{?with_python:--with-python}%{!?with_python:--without-python} \
--prefix=%{_prefix} --bindir=%{_bindir} \
--includedir=%{_includedir} --libdir=%{_libdir} \
--mandir=%{_mandir} --infodir=%{_infodir}