summaryrefslogtreecommitdiffstats
path: root/contrib/crossrpms/rtems4.10/bfin/rtems-4.10-bfin-rtems4.10-gdb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/crossrpms/rtems4.10/bfin/rtems-4.10-bfin-rtems4.10-gdb.spec')
-rw-r--r--contrib/crossrpms/rtems4.10/bfin/rtems-4.10-bfin-rtems4.10-gdb.spec17
1 files changed, 10 insertions, 7 deletions
diff --git a/contrib/crossrpms/rtems4.10/bfin/rtems-4.10-bfin-rtems4.10-gdb.spec b/contrib/crossrpms/rtems4.10/bfin/rtems-4.10-bfin-rtems4.10-gdb.spec
index 43b77801a4..4968eda408 100644
--- a/contrib/crossrpms/rtems4.10/bfin/rtems-4.10-bfin-rtems4.10-gdb.spec
+++ b/contrib/crossrpms/rtems4.10/bfin/rtems-4.10-bfin-rtems4.10-gdb.spec
@@ -102,8 +102,15 @@ BuildRequires: %{_host_rpmprefix}expat-devel
%if "%{_build}" != "%{_host}"
BuildRequires: %{_host_rpmprefix}termcap-devel
%endif
+%bcond_with system_readline
%endif
-BuildRequires: %{_host_rpmprefix}readline-devel
+
+%if 0%{?fedora} >= 12
+%bcond_with system_readline
+%else
+%bcond_without system_readline
+%endif
+%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
BuildRequires: %{_host_rpmprefix}ncurses-devel
%if "%{gdb_version}" >= "6.8.50"
@@ -132,10 +139,8 @@ cd gdb-%{gdb_version}
%{?PATCH0:%patch0 -p1}
cd ..
-%if "%{gdb_version}" >= "6.7"
# Force using a system-provided libreadline
-rm -f gdb-%{gdb_version}/readline/configure
-%endif
+%{?with_system_readline:rm -f gdb-%{gdb_version}/readline/configure}
%build
export PATH="%{_bindir}:${PATH}"
mkdir -p build
@@ -152,9 +157,7 @@ rm -f gdb-%{gdb_version}/readline/configure
--disable-win32-registry \
--disable-werror \
%{build_sim} \
-%if "%{gdb_version}" >= "6.7"
- --with-system-readline \
-%endif
+ %{?with_system_readline:--with-system-readline} \
%if "%{gdb_version}" >= "6.6"
--with-expat \
%endif