summaryrefslogtreecommitdiffstats
path: root/contrib/crossrpms/freebsd6.0/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/crossrpms/freebsd6.0/Makefile.am')
-rw-r--r--contrib/crossrpms/freebsd6.0/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/contrib/crossrpms/freebsd6.0/Makefile.am b/contrib/crossrpms/freebsd6.0/Makefile.am
index 62aabcaed8..bfc1cf0fe5 100644
--- a/contrib/crossrpms/freebsd6.0/Makefile.am
+++ b/contrib/crossrpms/freebsd6.0/Makefile.am
@@ -17,13 +17,12 @@ LIBS_SUBPACKAGES += target-libs.add
$(TARGET)-libs.spec.in: $(LIBS_SUBPACKAGES) Makefile.am
cat $(LIBS_SUBPACKAGES) | sed \
-e "s,[@]_prefix[@],$(prefix),g" \
- -e "s,[@]rpmprefix[@],$(rpmprefix),g" \
> $(TARGET)-libs.spec.in
CLEANFILES += $(TARGET)-libs.spec.in
@rpmprefix@$(TARGET)-libs.spec: $(TARGET)-libs.spec.in
sed \
- -e "s/@tool_target@/$(TARGET)/g" \
+ -e "s/[@]tool_target[@]/$(TARGET)/g" \
-e "s/[@]FREEBSD_VERS[@]/$(FREEBSD_VERS)/g" \
-e "s/[@]FREEBSD_RPMREL[@]/$(FREEBSD_RPMREL)/g" \
$(srcdir)/$(TARGET)-libs.spec.in > $@
@@ -49,13 +48,13 @@ $(TARGET)-binutils.spec.in: $(BINUTILS_SUBPACKAGES) Makefile.am binutils-sources
-e "/[@]SOURCES[@]/r ./binutils-sources.add" \
-e "/[@]SOURCES[@]/d" \
-e "s,[@]_prefix[@],$(prefix),g" \
- -e "s,[@]rpmprefix[@],$(rpmprefix),g" \
-e "s,rtems[@]osversion[@],rtems,g" \
> $(TARGET)-binutils.spec.in
CLEANFILES += $(TARGET)-binutils.spec.in
@rpmprefix@$(TARGET)-binutils.spec: $(TARGET)-binutils.spec.in
sed \
+ -e "s,[@]rpmprefix[@],$(rpmprefix),g" \
-e "s/[@]tool_target[@]/$(TARGET)/g" \
-e "s/[@]BINUTILS_VERS[@]/$(BINUTILS_VERS)/g" \
-e "s/[@]BINUTILS_RPMREL[@]/$(BINUTILS_RPMREL)/g" \
@@ -84,7 +83,6 @@ $(TARGET)-gcc.spec.in: $(GCC_SUBPACKAGES) Makefile.am gcc-sources.add
-e "/[@]SOURCES[@]/r ./gcc-sources.add" \
-e "/[@]SOURCES[@]/d" \
-e "s,[@]_prefix[@],$(prefix),g" \
- -e "s,[@]rpmprefix[@],$(rpmprefix),g" \
-e "s,rtems[@]osversion[@],rtems,g" \
-e "s,[@]tool_target[@]-libc,@tool_target@-sys-root,g" \
-e "s,[=<][ ]*%{newlib_version}-%{release},," \
@@ -97,6 +95,7 @@ CLEANFILES += $(TARGET)-gcc.spec.in
@rpmprefix@$(TARGET)-gcc.spec: $(TARGET)-gcc.spec.in
sed \
+ -e "s,[@]rpmprefix[@],$(rpmprefix),g" \
-e "s/[@]tool_target[@]/$(TARGET)/g" \
-e "s/[@]GCC_VERS[@]/$(GCC_VERS)/g" \
-e "s/[@]GCC_RPMREL[@]/$(GCC_RPMREL)/g" \