summaryrefslogtreecommitdiffstats
path: root/contrib/crossrpms/cygwin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/crossrpms/cygwin/Makefile.am')
-rw-r--r--contrib/crossrpms/cygwin/Makefile.am30
1 files changed, 29 insertions, 1 deletions
diff --git a/contrib/crossrpms/cygwin/Makefile.am b/contrib/crossrpms/cygwin/Makefile.am
index bd7b5ce983..54dacdb1d0 100644
--- a/contrib/crossrpms/cygwin/Makefile.am
+++ b/contrib/crossrpms/cygwin/Makefile.am
@@ -33,6 +33,33 @@ CLEANFILES += @rpmprefix@$(TARGET)-libs.spec
noinst_DATA += @rpmprefix@$(TARGET)-libs.spec
+W32API_VERS = 3.6-1
+W32API_RPMREL = @VERSION@
+EXTRA_DIST += target-w32api.add
+EXTRA_DIST += w32api.add
+
+W32API_SUBPACKAGES = $(top_builddir)/common/common.add
+W32API_SUBPACKAGES += w32api.add
+W32API_SUBPACKAGES += ../gcc/rpm-install.add
+W32API_SUBPACKAGES += $(top_builddir)/common/clean.add
+W32API_SUBPACKAGES += target-w32api.add
+
+$(TARGET)-w32api.spec.in: $(W32API_SUBPACKAGES) Makefile.am
+ cat $(W32API_SUBPACKAGES) | sed \
+ -e "s/[@]W32API_VERS[@]/$(W32API_VERS)/g" \
+ -e "s/[@]W32API_RPMREL[@]/$(W32API_RPMREL)/g" \
+ -e "s,%{gcc_rpmvers},%{w32api_rpmvers},g" \
+ > $(TARGET)-w32api.spec.in
+CLEANFILES += $(TARGET)-w32api.spec.in
+
+@rpmprefix@$(TARGET)-w32api.spec: $(TARGET)-w32api.spec.in
+ $(MKSPEC) $(srcdir)/$(TARGET)-w32api.spec.in > $@
+CLEANFILES += @rpmprefix@$(TARGET)-w32api.spec
+noinst_DATA += @rpmprefix@$(TARGET)-w32api.spec
+
+
+
+
BINUTILS_VERS = 20050610-1
BINUTILS_RPMREL = @VERSION@
EXTRA_DIST += binutils-sources.add
@@ -89,7 +116,8 @@ $(TARGET)-gcc.spec.in: $(GCC_SUBPACKAGES) Makefile.am gcc-sources.add gcc-prep.a
-e "s/[@]GCC_VERS[@]/$(GCC_VERS)/g" \
-e "s/[@]GCC_RPMREL[@]/$(GCC_RPMREL)/g" \
-e "/[@]tool_target[@]-newlib/d" \
- -e "/[@]tool_target[@]-w32api-sys-root/d" \
+ -e "/^BuildRequ.*[@]tool_target[@]-w32api-sys-root/d" \
+ -e "s,[@]tool_target[@]-w32api-sys-root,@tool_target@-w32api," \
-e 's,^%define build_newlib.*$$,%define build_newlib 0,' \
> $(TARGET)-gcc.spec.in
CLEANFILES += $(TARGET)-gcc.spec.in