summaryrefslogtreecommitdiffstats
path: root/c/src/wrapup/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/wrapup/configure.ac')
-rw-r--r--c/src/wrapup/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/c/src/wrapup/configure.ac b/c/src/wrapup/configure.ac
index 453bb81e8a..633eabfc2d 100644
--- a/c/src/wrapup/configure.ac
+++ b/c/src/wrapup/configure.ac
@@ -21,6 +21,11 @@ RTEMS_ENABLE_MULTILIB
RTEMS_ENV_RTEMSBSP
RTEMS_CHECK_CPU
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_BSP_ALIAS(${RTEMS_BSP},bspalias)
+
+# The bare bsp doesn't have libbsp.a
+# FIXME: We should use a feature based check, here
+AM_CONDITIONAL(HAS_LIBBSP,[! test "$bspalias" = "bare"])
RTEMS_CHECK_NETWORKING(RTEMS_BSP)
if test "$HAS_NETWORKING" = "yes"; then