summaryrefslogtreecommitdiffstats
path: root/c/src/support/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/support/Makefile.am')
-rw-r--r--c/src/support/Makefile.am11
1 files changed, 2 insertions, 9 deletions
diff --git a/c/src/support/Makefile.am b/c/src/support/Makefile.am
index 04b5b05114..2427bdee38 100644
--- a/c/src/support/Makefile.am
+++ b/c/src/support/Makefile.am
@@ -6,16 +6,9 @@ include $(top_srcdir)/automake/compile.am
AM_CPPFLAGS += -DRTEMS_BSP=\"@RTEMS_BSP@\"
-EXTRA_LIBRARIES = libsupport.a
-CLEANFILES = libsupport.a
+noinst_LIBRARIES = libsupport.a
+
libsupport_a_SOURCES = version.c
libsupport_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
-EXTRA_LIBRARIES += libsupport_g.a
-CLEANFILES += libsupport_g.a
-libsupport_g_a_SOURCES = $(libsupport_a_SOURCES)
-libsupport_g_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-
-noinst_DATA = libsupport$(LIB_VARIANT).a
-
include $(top_srcdir)/automake/local.am