summaryrefslogtreecommitdiffstats
path: root/c/src/optman/rtems/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/optman/rtems/Makefile.am')
-rw-r--r--c/src/optman/rtems/Makefile.am21
1 files changed, 2 insertions, 19 deletions
diff --git a/c/src/optman/rtems/Makefile.am b/c/src/optman/rtems/Makefile.am
index e594949876..dd0e847a5a 100644
--- a/c/src/optman/rtems/Makefile.am
+++ b/c/src/optman/rtems/Makefile.am
@@ -7,28 +7,11 @@ C_FILES = no-dpmem.c no-event.c no-msg.c no-mp.c no-part.c no-region.c \
no-rtmon.c no-sem.c no-signal.c no-timer.c
C_O_FILES = $(C_FILES:%.c=${ARCH}/%.$(OBJEXT))
-PGMS = $(C_FILES:%.c=$(ARCH)/%.rel)
+PGMS = $(C_FILES:%.c=$(ARCH)/%$(LIB_VARIANT).rel)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../../../automake/compile.am
include $(top_srcdir)/../../../automake/lib.am
-
-bsplib_DATA = $(PGMS)
-
-TMPINSTALL_FILES += \
- $(C_FILES:%.c=$(PROJECT_RELEASE)/lib$(MULTISUBDIR)/%$(LIB_VARIANT).rel)
-
-$(PROJECT_RELEASE)/lib$(MULTISUBDIR)/%$(LIB_VARIANT).rel: $(ARCH)/%.rel
- $(INSTALL_DATA) $< $@
-
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
-all-local: ${ARCH} $(PGMS) $(TMPINSTALL_FILES)
-
-.PRECIOUS: $(PGMS)
-
-EXTRA_DIST = $(C_FILES)
+include ../rel.am
include $(top_srcdir)/../../../automake/local.am