summaryrefslogtreecommitdiffstats
path: root/c/src/optman/rtems/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-11-08 17:57:06 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-11-08 17:57:06 +0000
commitc34635be66a922aad67af49a7b5f5ba54add6fb4 (patch)
treeaa72e977bf65be26a818ecec194aa2f3cf3e018d /c/src/optman/rtems/Makefile.am
parent2002-11-08 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-c34635be66a922aad67af49a7b5f5ba54add6fb4.tar.bz2
2002-11-08 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* rtems/Makefile.am: Reworked. * sapi/Makefile.am: Reworked. * rel.am: New.
Diffstat (limited to 'c/src/optman/rtems/Makefile.am')
-rw-r--r--c/src/optman/rtems/Makefile.am21
1 files changed, 2 insertions, 19 deletions
diff --git a/c/src/optman/rtems/Makefile.am b/c/src/optman/rtems/Makefile.am
index e594949876..dd0e847a5a 100644
--- a/c/src/optman/rtems/Makefile.am
+++ b/c/src/optman/rtems/Makefile.am
@@ -7,28 +7,11 @@ C_FILES = no-dpmem.c no-event.c no-msg.c no-mp.c no-part.c no-region.c \
no-rtmon.c no-sem.c no-signal.c no-timer.c
C_O_FILES = $(C_FILES:%.c=${ARCH}/%.$(OBJEXT))
-PGMS = $(C_FILES:%.c=$(ARCH)/%.rel)
+PGMS = $(C_FILES:%.c=$(ARCH)/%$(LIB_VARIANT).rel)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../../../automake/compile.am
include $(top_srcdir)/../../../automake/lib.am
-
-bsplib_DATA = $(PGMS)
-
-TMPINSTALL_FILES += \
- $(C_FILES:%.c=$(PROJECT_RELEASE)/lib$(MULTISUBDIR)/%$(LIB_VARIANT).rel)
-
-$(PROJECT_RELEASE)/lib$(MULTISUBDIR)/%$(LIB_VARIANT).rel: $(ARCH)/%.rel
- $(INSTALL_DATA) $< $@
-
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
-all-local: ${ARCH} $(PGMS) $(TMPINSTALL_FILES)
-
-.PRECIOUS: $(PGMS)
-
-EXTRA_DIST = $(C_FILES)
+include ../rel.am
include $(top_srcdir)/../../../automake/local.am