summaryrefslogtreecommitdiffstats
path: root/c/src/libnetworking/nfs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/libnetworking/nfs/Makefile.am')
-rw-r--r--c/src/libnetworking/nfs/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/c/src/libnetworking/nfs/Makefile.am b/c/src/libnetworking/nfs/Makefile.am
new file mode 100644
index 0000000000..51184e47ae
--- /dev/null
+++ b/c/src/libnetworking/nfs/Makefile.am
@@ -0,0 +1,35 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+LIBNAME = lib.a
+LIB = $(ARCH)/$(LIBNAME)
+
+C_FILES = bootp_subr.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/lib.am
+
+#
+# Add local stuff here using +=
+#
+
+AM_CPPFLAGS += -D_COMPILING_BSD_KERNEL_ -DKERNEL -DINET -DNFS -DDIAGNOSTIC \
+ -DBOOTP_COMPAT
+
+$(LIB): $(OBJS)
+ $(make-library)
+
+all-local: $(ARCH) $(OBJS) $(LIB)
+
+.PRECIOUS: $(LIB)
+
+EXTRA_DIST = bootp_subr.c krpc.h nfs.h nfsdiskless.h nfsproto.h rpcv2.h \
+ xdr_subs.h
+
+include $(top_srcdir)/../../../automake/local.am