summaryrefslogtreecommitdiffstats
path: root/c/src/libmisc/wrapup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/libmisc/wrapup/Makefile.am')
-rw-r--r--c/src/libmisc/wrapup/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/c/src/libmisc/wrapup/Makefile.am b/c/src/libmisc/wrapup/Makefile.am
index 834c1710a0..d4ee95b72b 100644
--- a/c/src/libmisc/wrapup/Makefile.am
+++ b/c/src/libmisc/wrapup/Makefile.am
@@ -11,11 +11,15 @@ include $(top_srcdir)/../../../automake/lib.am
## XXX temporarily remove this from the list because it causes a
## XXX number of BSPs to not link "main(){}" used by autoconf
## ../serdbg/$(ARCH)/libserdbg-tmp.a
-
+
+if RTEMS_LIBSHELL
+RTEMS_LIBSHELL = ../shell/$(ARCH)/libshell-tmp.a
+endif
+
TMP_LIBS = ../monitor/$(ARCH)/libmonitor-tmp.a \
../untar/$(ARCH)/libuntar-tmp.a ../stackchk/$(ARCH)/libstackchk-tmp.a \
../cpuuse/$(ARCH)/libcpuuse-tmp.a ../rtmonuse/$(ARCH)/librtmonuse-tmp.a \
- ../shell/$(ARCH)/libshell-tmp.a ../dumpbuf/$(ARCH)/libdumpbuf-tmp.a \
+ $(RTEMS_LIBSHELL) ../dumpbuf/$(ARCH)/libdumpbuf-tmp.a \
../devnull/$(ARCH)/libdevnull-tmp.a ../dummy/$(ARCH)/libdummy-tmp.a \
../mw-fb/$(ARCH)/libmw-fb-tmp.a ../capture/$(ARCH)/libcapture-tmp.a