summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7750/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libcpu/sh/sh7750/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sh/sh7750/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/sh/sh7750/Makefile.am b/c/src/lib/libcpu/sh/sh7750/Makefile.am
index 200d4ce1c8..44456183f0 100644
--- a/c/src/lib/libcpu/sh/sh7750/Makefile.am
+++ b/c/src/lib/libcpu/sh/sh7750/Makefile.am
@@ -82,10 +82,12 @@ PREINSTALL_FILES =
$(PROJECT_INCLUDE)/sh/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/sh
@: > $(PROJECT_INCLUDE)/sh/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sh/$(dirstamp)
$(PROJECT_INCLUDE)/rtems/score/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/rtems/score
@: > $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
$(PROJECT_INCLUDE)/sh/sh4uart.h: include/sh/sh4uart.h $(PROJECT_INCLUDE)/sh/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sh/sh4uart.h
@@ -111,4 +113,6 @@ $(PROJECT_INCLUDE)/rtems/score/sh4_regs.h: include/rtems/score/sh4_regs.h $(PROJ
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/sh4_regs.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/sh4_regs.h
+CLEANFILES = $(PREINSTALL_FILES)
+
include $(top_srcdir)/../../../../automake/local.am