summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/mpc8xx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libcpu/powerpc/mpc8xx/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/mpc8xx/Makefile.am21
1 files changed, 20 insertions, 1 deletions
diff --git a/c/src/lib/libcpu/powerpc/mpc8xx/Makefile.am b/c/src/lib/libcpu/powerpc/mpc8xx/Makefile.am
index 6df975c921..86fd518c6f 100644
--- a/c/src/lib/libcpu/powerpc/mpc8xx/Makefile.am
+++ b/c/src/lib/libcpu/powerpc/mpc8xx/Makefile.am
@@ -2,8 +2,27 @@
## $Id$
##
+SUBDIRS = . console-generic clock timer cpm mmu exceptions
-SUBDIRS = include console-generic clock timer cpm mmu exceptions
+include_mpc8xxdir = $(includedir)/mpc8xx
+
+include_HEADERS = include/mpc8xx.h
+include_mpc8xx_HEADERS = include/console.h include/cpm.h include/mmu.h
+
+PREINSTALL_FILES = $(PROJECT_INCLUDE)/mpc8xx \
+ $(include_HEADERS:include/%=$(PROJECT_INCLUDE)/%) \
+ $(include_mpc8xx_HEADERS:include/%=$(PROJECT_INCLUDE)/mpc8xx/%)
+
+$(PROJECT_INCLUDE)/mpc8xx:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/%.h: include/%.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/mpc8xx/%.h: include/%.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(PREINSTALL_FILES)
include $(top_srcdir)/../../../../../automake/subdirs.am
include $(top_srcdir)/../../../../../automake/local.am