summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/mpc6xx/wrapup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libcpu/powerpc/mpc6xx/wrapup/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/mpc6xx/wrapup/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/powerpc/mpc6xx/wrapup/Makefile.am b/c/src/lib/libcpu/powerpc/mpc6xx/wrapup/Makefile.am
new file mode 100644
index 0000000000..819c3a6c2b
--- /dev/null
+++ b/c/src/lib/libcpu/powerpc/mpc6xx/wrapup/Makefile.am
@@ -0,0 +1,31 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+# PROC_SPECIFIC_O_FILES = exceptions mmu clock
+PROC_SPECIFIC_O_FILES = exceptions mmu
+GENERIC_FILES =
+
+# bummer; have to use $foreach since % pattern subst rules only replace 1x
+OBJS = $(foreach piece, $(PROC_SPECIFIC_O_FILES), \
+ ../../mpc6xx/$(piece)/$(ARCH)/*.o) $(foreach piece, $(GENERIC_FILES), \
+ ../../mpc6xx/$(piece)/$(ARCH)/*.o)
+LIB = $(ARCH)/libcpuspec.a
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(LIB): ${OBJS}
+ echo $(OBJ)
+ $(make-library)
+ cp $(LIB) ..
+
+all-local: ${ARCH} $(LIB)
+
+include $(top_srcdir)/../../../../../automake/local.am