summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/mpc6xx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libcpu/powerpc/mpc6xx/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/mpc6xx/Makefile.am47
1 files changed, 5 insertions, 42 deletions
diff --git a/c/src/lib/libcpu/powerpc/mpc6xx/Makefile.am b/c/src/lib/libcpu/powerpc/mpc6xx/Makefile.am
index cec7359a2b..9e8f08ea5f 100644
--- a/c/src/lib/libcpu/powerpc/mpc6xx/Makefile.am
+++ b/c/src/lib/libcpu/powerpc/mpc6xx/Makefile.am
@@ -5,78 +5,41 @@
include $(top_srcdir)/../../../automake/compile.am
EXTRA_DIST =
-EXTRA_PROGRAMS =
+noinst_PROGRAMS =
CLEANFILES =
-noinst_DATA =
if mpc6xx
include_libcpudir = $(includedir)/libcpu
include_libcpu_HEADERS = exceptions/raw_exception.h
# exceptions
-EXTRA_PROGRAMS += exceptions.rel
-CLEANFILES += exceptions.rel
+noinst_PROGRAMS += exceptions.rel
exceptions_rel_SOURCES = exceptions/raw_exception.c exceptions/asm_utils.S
exceptions_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
exceptions_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-EXTRA_PROGRAMS += exceptions_g.rel
-CLEANFILES += exceptions_g.rel
-exceptions_g_rel_SOURCES = $(exceptions_rel_SOURCES)
-exceptions_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-exceptions_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_DATA += exceptions$(LIB_VARIANT).rel
-
# mmu
include_libcpu_HEADERS += mmu/bat.h mmu/pte121.h
-EXTRA_PROGRAMS += mmu.rel
-CLEANFILES += mmu.rel
+noinst_PROGRAMS += mmu.rel
mmu_rel_SOURCES = mmu/bat.c mmu/bat.h mmu/pte121.c mmu/pte121.h \
mmu/mmuAsm.S
mmu_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
mmu_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-EXTRA_PROGRAMS += mmu_g.rel
-CLEANFILES += mmu_g.rel
-mmu_g_rel_SOURCES = $(mmu_rel_SOURCES)
-mmu_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-mmu_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_DATA += mmu$(LIB_VARIANT).rel
-
# clock
include_libcpu_HEADERS += clock/c_clock.h
-EXTRA_PROGRAMS += clock.rel
-CLEANFILES += clock.rel
+noinst_PROGRAMS += clock.rel
clock_rel_SOURCES = clock/c_clock.c clock/c_clock.h
clock_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
clock_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-EXTRA_PROGRAMS += clock_g.rel
-CLEANFILES += clock_g.rel
-clock_g_rel_SOURCES = $(clock_rel_SOURCES)
-clock_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-clock_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_DATA += clock$(LIB_VARIANT).rel
-
# timer
-EXTRA_PROGRAMS += timer.rel
-CLEANFILES += timer.rel
+noinst_PROGRAMS += timer.rel
timer_rel_SOURCES = timer/timer.c
timer_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-EXTRA_PROGRAMS += timer_g.rel
-CLEANFILES += timer_g.rel
-timer_g_rel_SOURCES = $(timer_rel_SOURCES)
-timer_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-timer_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_DATA += timer$(LIB_VARIANT).rel
endif
## ----