summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/nios2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libcpu/nios2/Makefile.am')
-rw-r--r--c/src/lib/libcpu/nios2/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/nios2/Makefile.am b/c/src/lib/libcpu/nios2/Makefile.am
new file mode 100644
index 0000000000..25283a4d4f
--- /dev/null
+++ b/c/src/lib/libcpu/nios2/Makefile.am
@@ -0,0 +1,34 @@
+##
+## $Id$
+##
+
+ACLOCAL_AMFLAGS = -I ../../../aclocal
+
+include $(top_srcdir)/../../../automake/compile.am
+
+CLEANFILES =
+DISTCLEANFILES =
+noinst_PROGRAMS =
+
+if shared
+include_libcpudir = $(includedir)/libcpu
+
+## shared/cache
+include_libcpu_HEADERS = ../shared/include/cache.h
+noinst_PROGRAMS += shared/cache.rel
+shared_cache_rel_SOURCES = shared/cache/cache.c shared/cache/cache_.h \
+ ../shared/src/cache_aligned_malloc.c \
+ ../shared/src/cache_manager.c
+shared_cache_rel_CPPFLAGS = $(AM_CPPFLAGS) -I$(srcdir)/shared/cache
+shared_cache_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+## shared/misc
+noinst_PROGRAMS += shared/misc.rel
+shared_misc_rel_SOURCES = shared/misc/memcpy.c
+shared_misc_rel_CPPFLAGS = $(AM_CPPFLAGS) $(NIOS2_CPPFLAGS)
+shared_misc_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+endif
+
+include $(srcdir)/preinstall.am
+
+include $(top_srcdir)/../../../automake/local.am