summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/mips/mongoosev/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libcpu/mips/mongoosev/Makefile.am')
-rw-r--r--c/src/lib/libcpu/mips/mongoosev/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/c/src/lib/libcpu/mips/mongoosev/Makefile.am b/c/src/lib/libcpu/mips/mongoosev/Makefile.am
index 4c4246b787..5f53303f2b 100644
--- a/c/src/lib/libcpu/mips/mongoosev/Makefile.am
+++ b/c/src/lib/libcpu/mips/mongoosev/Makefile.am
@@ -9,16 +9,17 @@ SUBDIRS = duart vectorisrs
include_mipsdir = $(includedir)/libcpu
include_mips_HEADERS = include/mongoose-v.h
-$(PROJECT_INCLUDE)/libcpu:
- $(mkinstalldirs) $@
+all-local: $(PREINSTALL_FILES)
-$(PROJECT_INCLUDE)/libcpu/%.h: include/%.h
- $(INSTALL_DATA) $< $@
+PREINSTALL_FILES =
-PREINSTALL_FILES = $(PROJECT_INCLUDE)/libcpu \
- $(include_mips_HEADERS:include/%.h=$(PROJECT_INCLUDE)/libcpu/%.h)
+$(PROJECT_INCLUDE)/libcpu:
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/libcpu
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu
-all-local: $(PREINSTALL_FILES)
+$(PROJECT_INCLUDE)/libcpu/mongoose-v.h: include/mongoose-v.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/libcpu/mongoose-v.h
include $(top_srcdir)/../../../automake/subdirs.am
include $(top_srcdir)/../../../automake/local.am